Bug 65231 - EDITING: Allow changing the color for Track Changes without losing the differentiation between authors
Summary: EDITING: Allow changing the color for Track Changes without losing the differ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Track-Changes Options-Dialog
  Show dependency treegraph
 
Reported: 2013-06-01 09:32 UTC by bugquestcontri
Modified: 2020-05-12 07:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-06-01 09:32:52 UTC
Problem description: 
Currently when using the record changes setting "by Author", the  first author appears in a brownish color. This color is getting difficult to read if there are some changes made.

Enhancement request:
Enable a selection of different colors for each author without loosing the differentiation between  authors.
Operating System: All
Version: 3.6.6.2 release
Comment 1 Jorendc 2013-06-01 10:22:58 UTC
Valid enhancement request! Therefore marking it as such.

Kind regards,
Joren
Comment 2 Steve 2013-12-01 17:08:19 UTC
I also support this request
Comment 3 Jorendc 2013-12-01 17:37:40 UTC
(In reply to comment #2)
> I also support this request
@Steve: the version of a bug is the oldest version of LibreOffice you can reproduce that behavior. So, in this case it's an enhancement request, we can set it to unspecified because it isn't implemented at all.

Kind regards,
Joren
Comment 4 Coucouf 2016-02-21 21:16:12 UTC
Any news about this issue?
This change would be welcome.

It’s disappointing not to be able to change what looks like a simple thing from a user’s perspective.
Comment 5 RMonk 2016-05-01 10:06:52 UTC
Still hoping for news on this.  It needs fixing by allowing a user to select their own edit colour or by at least changing the default colours so that the first few are all properly visible and differentiated colours in use, not light and not too similar.  Removing the yellow/brown initial default colour would be a great start ... and simple given that more involved changes are obviously difficult given the years of no change on this bug.
Comment 6 mrodent33 2016-09-30 15:32:46 UTC
Echo previous two comments... it's truly undermining the usefulness of this feature when different colours are used each time.  In addition to some of the colours used (e.g. light brown) being quite hard on the eyes, much much more important is that it is natural to the human brain to have consistency: Ms A's stuff is using dark blue for her changes; Mr B is using dark red; Dr C is using dark green...
Comment 7 RonnyC 2016-10-11 08:49:45 UTC
I completely agree with 'mrodent33@yahoo.co.uk'. This feature would be a major enhancement for all people collaborating and writing documents together. 

Just to repeat with different word what 'mrodent' said:
It would be nice to have a menu to change the tracking colour for the first, second, third ... author myself. Maybe one could handle colours for specific authors (identified by name and than in the changes even have the same colour in all edited documents).
Comment 8 kuggdyar 2017-06-23 01:22:10 UTC
I add my support for this enhancement request.
Comment 9 CaroZ 2017-07-05 10:50:08 UTC
I support this request, it would be great
Comment 10 Luka Oman 2017-07-29 16:18:12 UTC
Any hope this 4 years old request to see the light of day? It would make our lives more colorful, ehm, easier.
Comment 11 Dan Carr 2018-01-25 21:49:37 UTC
I would like to add my endorsement for this change.  The colors selected for tracking changes are hard to view.  To work around this issue, I was forced to load a multi-page document into a table and use one column to identify changes which were sometimes a single character used to correct a misspelling and a third column to identify author.
Comment 12 Dan Carr 2018-01-25 22:03:01 UTC
Sorry for the comment: 
This item has been fixed: 
Go to Tools-Options-Writer-Changes  and you may select from the color palate for each type of change.
Comment 13 Thomas Lendo 2018-06-02 20:52:23 UTC
Closing the bug as RESOLVED WORKSFORME according to comment 12.

If someone knows the patch that fixed this issue, please comment and change the status to RESOLVED FIXED.

If this bug isn't fixed completely, please reopen with status NEW.
Comment 14 jan 2018-10-29 17:33:39 UTC
Request was not fixed at all - the title specifically says that the fix should keep differentiation between authors awailable. The fix mentioned in comment #12 doesn't provide that (applying it would cause all authors' changes to have the same colour).

We need this a lot, the default colours are also hard to read by colorblind people or users of flux/redshift apps (these filter blue light during evening/night time to reduce eye strain).
Comment 15 jano31coa 2018-12-04 10:40:29 UTC
I completely agree with this post. We use record changes a lot at work, and this is definitely making things difficult for people to switch from MSWORD.
With LO WRITER you can change the color, but then it's the same color for all "Authors". You can choose that each "Author" gets a different color, but the default colors are bad. Some are difficult to read on the screen, and some others are difficult to read on printed material, which is really frustrating.

Is there a way to make this happen faster ? give money for someone to fix this ?
Comment 16 Jim Avera 2018-12-09 01:09:10 UTC
Can we just change the default (first author) color to a *readable* color?

The yellow/gold color is horrible, as many people have said here and elsewhere.  Just change it to something darker and think about a proper fix later...

(I suspect that the fix we really want might break MS Word compatibility.  But just making the current algorithm use readable colors should be relatively easy?)
Comment 17 mrodent33 2020-01-14 20:57:31 UTC
6 and a half years after this enhancement was first requested, and no action.

How difficult can it be? At the very least, please just exclude very light colours, which are hard to read at the best of times, and guaranteed to produce eye-strain in many environments where people will be using LO Writer.

... I'm half tempted to examine the source code myself ... but I have no idea how to recompile or whatever. What's LO written in? C++ or something?

What we need as the first default colours for the different authors is a rich, deep blue, a rich, deep green, a rich, deep purple, etc... NOT "YELLOW-GOLD".

Even better, of course, would be if the colours could be specifically chosen.

When feature requests are being considered by the development team, surely there should be judgement balancing up the difficulty of implementing a proposed enhancement against the difficulty, irksomeness or, in this case, also potentially detrimental effect on health (eye-strain due to horrible "yellow-gold") which users have to tolerate.

Please just tweak the default colours at least!!!
Comment 18 mrodent33 2020-01-14 21:32:12 UTC
OH! Just upgraded to LO version 6.3.4... and it appears as though the vile "yellow-gold" has in fact ... GONE!

When I start a new doc and settings are for "by Author", the first colour appears to be a light green (not ideal but tolerable), then (i.e. after a change of Tools --> Options --> LibreOffice --> User data --> User name --> First/last name/initials) a blue, then a violet.

But no mention of this here in this "enhancement request" strand, which is interesting.

Can still be improved, but at least the "eye-strain" yellow-gold is gone.
Comment 19 mrodent33 2020-01-14 21:53:28 UTC
Ooops, spoke too soon (and you can't delete comments here). The problem is NOT solved (even partially) in LO 6.3.4. It's just that *sometimes* the sequence of colours appears to start with a colour other than "yellow-gold".  

It's not clear how this "By Author" colour sequence is determined when you start a new document. My experiments seem to indicate that the User's "first/second name/initials" may be being used as a variable to seed some random selector. I'd have to look at the source ...
Comment 20 doko 2020-05-12 07:43:58 UTC
Could you finally do something about it? Common, it can't be so hard to do it. Either change default colors to something more visible like blue or better give people freedom to apply any color they want. Please _/|\_