Download it now!
Bug 65241 - FORMATTING: Incorrect formatting text and colors of cells when opening in xlsx-files in Calc
Summary: FORMATTING: Incorrect formatting text and colors of cells when opening in xls...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other All
: medium major
Assignee: Noel Power
URL:
Whiteboard: interoperabillity
Keywords: regression
: 65183 65706 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-06-01 11:32 UTC by mikhail.v.gavrilov
Modified: 2013-11-21 16:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document (114.32 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-01 11:32 UTC, mikhail.v.gavrilov
Details
screenshot LibreOffice Calc (192.91 KB, image/png)
2013-06-01 11:33 UTC, mikhail.v.gavrilov
Details
screenshot MS Office Excel (116.33 KB, image/png)
2013-06-01 11:35 UTC, mikhail.v.gavrilov
Details
An other file that has this problem (12.46 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-02 19:40 UTC, Thomas van der Meulen
Details
good file loading on 4.0.4 (144.00 KB, image/png)
2013-06-06 13:25 UTC, Thomas van der Meulen
Details
bad file loading in 4.1 b1+b2 (49.17 KB, image/png)
2013-06-06 13:26 UTC, Thomas van der Meulen
Details
Test file with the example (33.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-06 14:30 UTC, Maximiliano Castañón
Details
Test file with the example .ODS (25.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-06 14:31 UTC, Maximiliano Castañón
Details
file saved with LO 4.0.4 to XLSX (19.58 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-06 21:45 UTC, Maximiliano Castañón
Details
file saved with LO 4.0.4 to XLS and looks fine with LO 4.1 (41.00 KB, application/vnd.ms-excel)
2013-06-06 21:47 UTC, Maximiliano Castañón
Details
pdf with results of xlsx in two versions (75.06 KB, application/pdf)
2013-06-09 13:25 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.v.gavrilov 2013-06-01 11:32:14 UTC
Created attachment 80133 [details]
Example document

Incorrect formatting in LibreOffice Calc

for example:
1) rows 64-69 have red ink.
2) rows 70-75 have yellow paper.
3) rows 76-79 have green ink.
4) all borders are thin.
Comment 1 mikhail.v.gavrilov 2013-06-01 11:33:55 UTC
Created attachment 80134 [details]
screenshot LibreOffice Calc
Comment 2 mikhail.v.gavrilov 2013-06-01 11:35:22 UTC
Created attachment 80135 [details]
screenshot MS Office Excel
Comment 3 Thomas van der Meulen 2013-06-02 19:39:34 UTC
Thank you for your bug report, I can reproduce this bug running libreoffice Version: 4.1.0.0.beta1
Build ID: 3a2c2d2417101e45fe07cfd8358acf2204a98f3 on Mac osx 10.8.3 

I have an other file that has the same problem I will add it.
Comment 4 Thomas van der Meulen 2013-06-02 19:40:34 UTC
Created attachment 80164 [details]
An other file that has this problem
Comment 5 Thomas van der Meulen 2013-06-03 15:53:11 UTC
*** Bug 65183 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2013-06-06 08:50:59 UTC
Hi thomas,

(In reply to comment #4)
> An other file that has this problem

Can you pls update the summary of the issue, so that is clear immediately what is wrong and possibly when/in which circumstances ? Would be lovely :)
thanks - Cor
Comment 7 Thomas van der Meulen 2013-06-06 13:25:14 UTC
@Cor, Wenn you open the file your will see black fields with with text in them, wenn you opens it with 4.0.X (Version 4.0.4.1 (Build ID: 7fdd5ee61c1c7379dd088f5d50265f0adbccf53)) these black fields are shown the correct collor.


ps: tested it again with Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6  and stil got the problem
ps2: I think this is serieus and might be a MAB bug!
Comment 8 Thomas van der Meulen 2013-06-06 13:25:45 UTC
Created attachment 80400 [details]
good file loading on 4.0.4
Comment 9 Thomas van der Meulen 2013-06-06 13:26:10 UTC
Created attachment 80401 [details]
bad file loading in 4.1 b1+b2
Comment 10 Maximiliano Castañón 2013-06-06 14:30:35 UTC
Created attachment 80412 [details]
Test file with the example

this file is related to the problem of formatting, it's just a formatting problem or probably interpretation because I have saved it in ODS and opened with LO 4.1 beta 1 and it show the rigths colors so I guess the problem might be from formatting.
Comment 11 Maximiliano Castañón 2013-06-06 14:31:39 UTC
Created attachment 80415 [details]
Test file with the example .ODS

This file works fine with LO 4.1 beta but with ODS.
Comment 12 Thomas van der Meulen 2013-06-06 14:46:25 UTC
Yes I think it might be .xsl(x) files only. because that .ods opens with out a problem and the xslx has to problem.
Comment 13 Maximiliano Castañón 2013-06-06 21:45:25 UTC
Created attachment 80437 [details]
file saved with LO 4.0.4 to XLSX

This file comes from the file who looks bad in LibreOffice 4.1 but looks ok in LO 4.0.4 

I saved it using the XLSX from the LO 4.0.4 and it looks terrible...
Comment 14 Maximiliano Castañón 2013-06-06 21:47:20 UTC
Created attachment 80438 [details]
file saved with LO 4.0.4 to XLS and looks fine with LO 4.1

This file were save with LO 4.0.4 and looks fine in LO 4.1
Comment 15 Cor Nouws 2013-06-09 13:25:38 UTC
Created attachment 80566 [details]
pdf with results of xlsx in two versions
Comment 16 Noel Power 2013-06-10 09:39:02 UTC
can't reproduce with latest build of 4.1 branch :-/ ( will check master also ) most likely this has been fixed
Comment 17 Noel Power 2013-06-10 10:18:38 UTC
(In reply to comment #16)
> can't reproduce with latest build of 4.1 branch :-/ ( will check master also
> ) most likely this has been fixed

strangely I see the same problem on master ( perhaps some patch got reverted then on 4.1 )
Comment 18 Noel Power 2013-06-10 10:30:50 UTC
I'll take it
Comment 19 Noel Power 2013-06-10 10:36:38 UTC
aha ( and I should really have twigged this ) http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-1&id=9bf6c83367cedb7be81bf67f30d2147d26c7a8 fixes this, Stephan has planned a different fix for this in master
Comment 20 Stephan Bergmann 2013-06-17 09:01:55 UTC
(In reply to comment #19)
> http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-
> 1&id=9bf6c83367cedb7be81bf67f30d2147d26c7a8 fixes this, Stephan has planned
> a different fix for this in master

master fix is <http://cgit.freedesktop.org/libreoffice/core/commit/?id=3af0114a295d2a6c600117adb5bcd6689c0c787e> "Introduce O[U]String::toUInt32"
Comment 21 GerardF 2013-06-21 16:42:42 UTC
*** Bug 65706 has been marked as a duplicate of this bug. ***