Bug 65259 - CONFIGURATION: paragraph style sheets in in wrong language when using wizard
Summary: CONFIGURATION: paragraph style sheets in in wrong language when using wizard
Status: RESOLVED DUPLICATE of bug 75218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2013-06-02 09:55 UTC by Fabian
Modified: 2018-10-17 18:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Paragraph language setting (79.79 KB, image/png)
2013-06-19 05:10 UTC, Fabian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2013-06-02 09:55:59 UTC
Problem description: 
I have had this problem for several versions now and I can't really take it any longer.

I'm using the German release of LibreOffice 4.0.3.3 installed on Windows 7 64bit. But the bug also occurs on different other versions of LibreOffice running under Windows (XP, Vista and 7), Ubuntu Linux 10.04 LTS, 12.04 LTS, Linux Mint and others.

So it's neither version specific nor is it dependent on the used operating system. You can consider this ruled out to begin with. Thank you.

Whenever creating a new document (in Writer) using the wizard the resulting document is set up completely wrong.

It starts with the page setup: the paper format is set to "Letter". That might be fine in the U.S. of A. but here in Europe we use a more sensible DIN format paper called "A4". So in order for the printout to work I need to reset this manually which defeats the purpose of this wizard. Also: this means that the folding marks (which I find useful if I have to send a letter, doh) are in a completely wrong place.

Then we go on to the paragraph style sheets:
All of them are set to default language "English". This has direct influence on a couple of settings, not least the spellchecker.
Well, guess what, not all people in the world speak English as their native language. So, since the operating system I'm running LibreOffice is set to "German" and LibreOffice itself is the German version, I'd expect everything -- and I mean *everything* -- set to German defaults.

Because if this isn't set automatically in such a way, then it defeats the purpose of templates and wizards. It is just more work with them, than without them.

And in case you're wondering why I'm not polite: I reported this bug two years ago already. Nobody seemed to care, nobody seemed to think this was an issue, nobody fixed it. Instead the old bugreport was closed without taking action.

It's easy: just have wizards and templates check for the language of the operating system. It really is easy.

If LibreOffice is to step up against things like Microsoft Office, you really need to fix that.
Oh, by the way: this has worked in OpenOffice.org 3.x -- I don't know, maybe you need to get some of the old sources back. Maybe during your code-cleanup you lost all the important bits ... just a hunch.

Steps to reproduce:
see above

Current behavior:
see above

Expected behavior:
see above
              
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 retired 2013-06-02 10:59:44 UTC
Setting OS X to ALL as per bug description.
Fabian: thanks for taking the time to report this.

Please note our policy to only have one issue per bug. So from what I read this covers two problems:

1) LO > Wizards > Letter: folding marks in german language (aka DIN A4 paper) are off: CONFIRMED, thus setting to NEW.

2) Paragraph style sheets: that would be a separate bug. But for me when opening german LO 4.0.3.3 I see http://cl.ly/image/1X2c0a1M2n1k so all is translated. For 4.1b1 is not yet fully translated but that is ongoing and will be finished for the final release. So maybe just ignore that for now?

Fabian, could you please provide a link to that old bug report? If it was closed in error you can re-open it and elaborate on your thoughts.
Comment 2 Fabian 2013-06-19 05:10:14 UTC
Created attachment 81049 [details]
Paragraph language setting
Comment 3 Fabian 2013-06-19 05:21:19 UTC
Thank you for your kind response and sorry for being so harsh in the first place. Sorry, too, for not replying earlier.

Several things:
Re 1) Please note that this problem occurs only because the wizard creates a document with the wrong paper format selected. If the wizard from a German setup would create DIN A4 documents in the first place, the folding marks would be in the correct place anyway. So let me stress again: the real issue is not the misaligned folding marks, the real issue is that the wizard produces documents with paper size "Letter" selected instead of the more sensible DIN A4. And to know that A4 would be in order is easy to find out: just read the language localization setting of the underlying operating system and if this results in "German" or "Deutsch" or "Deutschland" or "DE" or any other permutation along the way: just make a DIN A4 document.

Re 2) Thank you for your screenshot, but I have to say, that's not at all related to the problem I described. I wasn't talking about the localisation of the software itself, but the language selection in the configuration of the paragraph template (zu Deutsch: Absatzvorlage). I attached a little screenshot to make it clear. In this screenshot the language setting is correct, but: if you look at a document created by the wizard we have the language set to English, which is really wrong if you're in a German setup.

That last point -- the wizard creating documents with the language setting for the paragraphs set up wrong -- brings me neatly to your note about your policy. You see, I think those two issues are very closely related and may even have the same source.
Here's why: Having the page set up to Letter instead of DIN A4 in a German setup and at the same time having the paragraph language setting to English instead of German is really the same thing. Letter and English language setting vs. A4 and German language setting. One thing is set up for English (American) needs, while the other is set up for German needs.
I maintain therefore that this is exactly one bug and should be treated that way, otherwise there's the risk of getting one part of it fixed while the other is not. And that's just no fix at all.

Re old bugreport. I will try to find it and post again. I may have used a different user account at that time.
Comment 4 Fabian 2013-06-22 10:49:14 UTC
ok, I have checked now. Unfortunately I can't seem to find the old bugreport anymore. Sorry. It wouldn't really help anyway, because the problem I reported back then seemed to look different, even though it is exactly this. This may sound a bit weird, but that's the wey it is.

So ... seems nobody took another look at it so far.
Comment 5 QA Administrators 2015-03-16 23:41:33 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2015-03-28 17:36:46 UTC
The Letter wizard is not intended to create a new document but a new template. When you have created and modified (e.g. to change page format and language) your new template, you don't need to launch the wizard anymore. You only have to create a new document from your template.

Works as expected for me, even in the old 4.0 version.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 7 Fabian 2015-04-03 07:53:23 UTC
Since you want to be pedantic: Yes, the wizard creates a template. That doesn't change the fact that the template needs to be the correct paper size. It makes a huge difference for the position of the folding marks if the paper size is letter or A4. Since I am in Europe where we use metric measurements I want the template to be in A4 not in stupid U.S. letter. The folding marks are not at the right position even if I change the paper size afterwards. Is that really so diffcult to understand? Of course I know how to change paper sizes after the fact but that's not the point of a wizard, right?

So, the bug is still a bug and needs fixing. At least if LibreOffice ever wants to step up against MS Office, which incidently doesn't make that stupid mistake.

It is part of a correct localisation to make sure the wizard does use the correct paper sizes. It is a siple fact that if LibreOffice is installed and run in a German environment it will have to use A4 or A5 or A3 or some sort of DIN format. Letter is nowhere to be found here in Germany at least.

And just to reiterate: This bug has been in LibreOffice since the very beginning. That's four years! It is a bug regardless whether we're talking about a template or a document. Don't be so pedantic!

Regards
Fabian
Comment 8 Fabian 2015-04-03 08:12:16 UTC
I would like to add something more. First, please read my previous message carefully even if it is not polite. I would have been polite if this was a new bug (and please: it is a bug, come on), but it is not new. This bugreport alone is almost two years old and you don't seem to care one way or the other. You may be understaffed, but it is a really annoying bug.

By the way, it is not true that you only have to run the wizard once and then never again. What if I need private and business letter templates? Thought about that? Apparently not.

What's more: If I have to correct paper sizes, folding marks, paragraph languages and the positioning of the address fields (which are not correct if paper size changes from U.S. letter to A4), then why is there a wizard in the first place? If there is a wizard (and there is as we know) it has to make all the magic magically happen on its own, otherwise what's the point of the wizard. Right?

Regards
Fabian
Comment 9 Fabian 2015-04-07 12:48:47 UTC
Okay, so ... you're abandoning this bug? Why?
By the way, I want to remind you that everything which you need to know is in the initial bug-report. It's just another case of haven't read it properly.

As it stands now, I would recommend removing the wizard altogether, because it doesn't seem to do anything useful.

It is a shame that a two year old usability bug is still unsolved and was even considered as "works for me". You know: that label "works for me" is a big insult, I'd remove that as well.

Even if LibreOffice is available at no cost, I would have thought that the developers take such a bugreport a bit more seriously. I am really disappointed.
Comment 10 Adolfo Jayme 2015-05-13 01:55:41 UTC
I would say this is confirmed, so → NEW
Comment 11 Fabian 2015-05-21 03:48:58 UTC
Question: Does this mean that this bugreport is finally being treated?

Please read my initial (long) posts from 2013. All this still applies. Read them carefully. This is not meant as an offence but as a word of caution to save us all a lot of time.

Let me at this point remind you, that the bug which I am reporting here, was not present in OpenOffice.org 3.x series (which LibreOffice is supposed to be based on). So that begs to question how this bug was introduced in the first place. And it also tells you that this bug can indeed be fixed.

What's more: please spare us all the trouble of setting this to something like "WorksForMe". Right? Thank you.
Comment 12 Fabian 2015-07-01 20:17:26 UTC
Hey, it's me again ...
I took the liberty to reset to version 4.4.3.2 since the bug-report is now really properly ancient.

I can only hope that you take that seriously!

The bug is still exactly the same in version 4.4.3.2 like I reported initially TWO YEARS AGO! (Sorry for shouting.) I just tested with the recent Linux Mint 17.2 Cinnamon release which contains LibreOffice version 4.4.3.2 as standard.

To reiterate: this is a bug which really, really needs fixing.
Comment 13 Fabian 2015-08-03 21:32:16 UTC
Re-checked with LibreOffice 3.5.7.2 German (Linux Mint 13; clean install; language pack German)
Result:
Letter wizard creates template/document with correct layout DIN A4 -> folding marks at the correct position; text frames at the correct position; ZIP in front of name of the city (as it should be).

It is just like I said all along: in version 3.x this bug was not present and it was introduced later.

I hope you're satisfied. By the way: that would have been your job to check for that. Now it's your turn.
Comment 14 QA Administrators 2016-09-20 10:21:01 UTC Comment hidden (obsolete)
Comment 15 Fabian 2017-01-04 18:33:46 UTC
Thank you. Retested the bug on Microsoft Windows 7 64bit German (!) with the latest Version of LibreOffice 5.2.4 64bit German (!) as per download today.

The bug is still present, no change in behaviour.

Two more years and not a fix in sight. Unbelievable. Could someone please take care of this? Greatly appreciated.
Comment 16 Fabian 2017-01-05 11:00:30 UTC
One more thing to note: Tested this exact bug on Apache OpenOffice 4.1.3 (current release; downloaded today): Apache OpenOffice works correctly and does not have this bug.
Comment 17 Fabian 2017-01-05 11:02:52 UTC
Please also see Bug 75218. No duplicate!

https://bugs.documentfoundation.org/show_bug.cgi?id=75218
Comment 18 QA Administrators 2018-01-06 03:31:44 UTC Comment hidden (obsolete)
Comment 19 Fabian 2018-01-06 17:46:16 UTC
Bug still exists. Can you please fix it already?

It is a regression!

In fact it is now even worse with LibreOffice 6.0 because now there is no German translation of the wizard anymore. Why did you do that? Why are you hellbent on making the wizard worse and worse with each version of LibreOffice?

If you can't be bothered to fix the wizard then why not remove it altogether?! As it stands the wizard is now worse than useless.

Thank you for doing nothing in this regard for almost five years. I might switch to Apache OpenOffice.org.
Comment 20 Thomas Lendo 2018-09-22 22:50:11 UTC
Adding keyword needsUXEval to get more input.
Comment 21 Thomas Lendo 2018-10-16 20:07:33 UTC
I make this bug to a duplicate to the other bug. The other one was created later but has more followers, more dev and bibisect information and the wizard problem is generally (better) described in the summary.

And both bugs have nearly the same comments from the bug opener so there is no benefit to have two bugs with the same source cause.

*** This bug has been marked as a duplicate of bug 75218 ***