Bug Hunting Session
Bug 65261 - WebDAV: LibO doesn't handle vnd.sun.star.webdav protocol out-of-the-box
Summary: WebDAV: LibO doesn't handle vnd.sun.star.webdav protocol out-of-the-box
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA needsWebDAV
Keywords:
Depends on:
Blocks: WebDAV
  Show dependency treegraph
 
Reported: 2013-06-02 10:27 UTC by Jonathan Pasquier
Modified: 2018-04-17 22:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Pasquier 2013-06-02 10:27:09 UTC
Libreoffice is able to open documents located on a WebDAV server if provided with an URL starting with the vnd.sun.star.webdav protocol.
(for instance: vnd.sun.star.webdav://example.com/webdav/my-document.odt )

Unfortunately, after installing Libreoffice on Ubuntu these URL aren't still handled correctly.

Whether you click on a link in your browser or you try to open the URL from the command line with xdg-open vnd.sun.star.webdav://... you get a message saying that this protocol is unknown.

What I expected was that LibreOffice would start and would open the document.

A workaround is to create a Desktop file with the following informations:
[Desktop Entry]
Name=WebDav LibreOffice
Exec=/usr/bin/libreoffice %u
Type=Application
Terminal=false
Categories=System;
MimeType=x-scheme-handler/vnd.sun.star.webdav;

and then to copy it in /usr/share/applications
Afterwards you have to run sudo update-desktop-database so that Ubuntu will take the new protocol into account.

A more definitive solution would be to modify the libreoffice-base Desktop file that comes with libreoffice (also located in /usr/share/applications) to add the MimeType properties described above.

Note: I have also filled a bug report in Ubuntu's launchpad, but the comment in the desktop file state that it is part of the LibreOffice project. As I'm not sure which project is able to fix this bug, I've open a bug report on both bugtrackers. Sorry for the mess!
Launchpad bug report: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1186702
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 tommy27 2014-07-01 03:57:57 UTC
is this issue still reproducible with current LibO 4.2.5.2 release?
Comment 2 tommy27 2014-10-24 07:03:17 UTC
It would be nice to have the bug retested on a newer LibO version (4.3.2.2 is out) than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never
closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of
LibreOffice 
2) If it is present please leave a comment telling us what version of
LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a
short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that
is not appropriate in this case)
Comment 3 Alex Thurgood 2015-01-03 17:39:08 UTC
Adding self to CC if not already on
Comment 4 tommy27 2015-02-27 21:12:28 UTC
please retest with LibO 4.3.6.2 or 4.4.1.2 and give update of the bug status
Comment 5 Rolf Leggewie 2015-08-12 17:33:33 UTC
Thank you for reporting this issue, Jonathan and thank you for retesting against 4.4.2.2 as documented in https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1186702/comments/9 (issue is still unresolved as per that comment)
Comment 6 Giuseppe Castagno (aka beppec56) 2015-08-13 16:14:40 UTC
Retest with:

- LO Version: 5.0.0.5, Build ID: 437e4abdf9e72fd0a6e6f8697a0e659bc77f9b10, TDF distribution;
- on a Linux X86_64 machine;
- on local Apache2 WebDAV server
(vnd.sun.star.webdav://192.168.1.40/webdav/Lorem_ipsum.odt)
- OS is Ubuntu 14.04 LTS;

the protocol vnd.sun.star.webdav worked.
Comment 7 tommy27 2015-08-14 07:56:10 UTC
@Giuseppe
so could we mark this as RESOLVED?

@Rolf
can you confirm it works using LibO 5.0.0.5?
Comment 8 Giuseppe Castagno (aka beppec56) 2015-08-14 08:17:52 UTC
(In reply to tommy27 from comment #7)
> @Giuseppe
> so could we mark this as RESOLVED?

I've just checked on Windows 7 32bit, LO 5.0.0.5,
LO build id: 1b1a90865e348b492231e1c451437d7a15bb262b, works as well.

I think this can be marked as RESOLVED.

Users can of course reopen it if they think it's the case.
Comment 9 tommy27 2015-08-14 15:57:29 UTC
ok RESOLVED WORKSFORME

feel free to REOPEN if other users still see this bug in LibO 5.0.0
Comment 10 vladislav.kuzma 2016-11-02 09:00:55 UTC
Linux Ubuntu: 16.04
LibreOffice: 5.1.4.2

After installing LibreOffice url links with protocol vnd.sun.star.webdav aren't bound to LibreOffice.
After appending libreoffice-startcenter.desktop file property MimeType with x-scheme-handler/vnd.sun.star.webdav, it starts opening url links correctly with LibreOffice.
Comment 11 Buovjaga 2016-11-02 12:01:46 UTC
Correcting status to NEW.
Comment 12 QA Administrators 2017-11-04 09:00:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug