Bug 98881 - Installer shoud register protocols vnd.sun.star.webdav and vnd.sun.star.webdavs
Summary: Installer shoud register protocols vnd.sun.star.webdav and vnd.sun.star.webdavs
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Installer-Windows
  Show dependency treegraph
 
Reported: 2016-03-25 12:30 UTC by FeelAirSlow
Modified: 2021-06-28 10:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Reg file to declare protocols for Windows (1.12 KB, text/x-ms-regedit)
2016-03-25 12:30 UTC, FeelAirSlow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FeelAirSlow 2016-03-25 12:30:37 UTC
Created attachment 123839 [details]
Reg file to declare protocols for Windows

Custom URL protocols "vnd.sun.star.webdav" and "vnd.sun.star.webdavs" works well with the command line (with url like "vnd.sun.star.webdav://mywebdavserver/myfile.odt" for instance).

But as these protocols are not registered by default in Windows, when I click an hyperlink with this url in an html page, nothing happens.

So I use the attached Windows reg file to declare that these protocols are handled by LibreOffice.

But it would be easier if it could be done automatically during the installation process.
Comment 1 Buovjaga 2016-04-04 16:37:14 UTC
Ok, I guess I'll set to NEW.
Comment 2 Mike Kaganski 2021-01-15 09:34:58 UTC
vnd.sun.star.webdav (vnd.sun.star.webdavs) are *internal* schemes, not intended for use outside of LO process. Normal WebDAV URLs are simple HTTP(S) URLs. We should not register such URLs anywhere.