Bug 65301 - EDITING: Closing REPORT-Builder after editing report - crash of whole LO
Summary: EDITING: Closing REPORT-Builder after editing report - crash of whole LO
Status: RESOLVED DUPLICATE of bug 64279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.4.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-06-03 14:40 UTC by Robert Großkopf
Modified: 2013-06-04 21:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-06-03 14:40:17 UTC
Open a database.
Start to create a report in design-view.
Save the report in the report-window.
Close the report-window (File → Close or the "x" of the window).
Base crashes immediately.

Seems to be the same: 
Try to open a report for editing.
Base crashes immediately.

Next start of LO the recovery starts.

My System:
OpenSUSE 12.3 64bit, LO 4.0.4.1, Java openjdk 1.7.0_21 (same with java 1.6.0_22)

The error-log starts as followed:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f7fd08f2a80, pid=6024, tid=140188229523456
#
# JRE version: 7.0_21-b02
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsvxcorelo.so+0x411a80]  SdrObject::setUnoShape(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> const&)+0x0
Comment 1 David Tardon 2013-06-04 09:58:26 UTC
It does not crash for me on libreoffice-4-0 branch, so I assume this is the same problem as in bug 64279.

*** This bug has been marked as a duplicate of bug 64279 ***