Bug Hunting Session
Bug 65305 - python stuff broken in LO 4.1 on Windows (wizards, mail merge)
Summary: python stuff broken in LO 4.1 on Windows (wizards, mail merge)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: All Windows (All)
: high critical
Assignee: David Tardon
URL:
Whiteboard: target:4.2.0 target:4.1.0.0.beta2
Keywords:
: 65307 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-06-03 15:53 UTC by Petr Mladek
Modified: 2013-09-27 16:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2013-06-03 15:53:13 UTC
It seems that the python stuff is broken in LibreOffice 4.1 on Windows.

I have tested 4.1.0.0.beta1 build and also the last daily build libreoffice-4-1~2013-06-02_18.17.35_LibreOfficeDev_4.1.0.0.beta1_Win_x86.msi. I see the following problems:


+  Wizards do not work:

    1. Try "File/Wizards/Letter"

    Result: nothing happens


+ mail merge test shows a python error message:

    1. Open any new text document in Writer
    2. Open the dialog "Tools/Options/LibreOffice Writer/Mail Merge E-mail"
    3. Press [Test Setting]

    Result: Error message:

--- cut ---
LibreOfficeDev could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOfficeDev. Check the server name, the port and the secure connections settings
--
python-loader:<class 'ImportError'>: No module named '_socket', traceback follows
Could not load uno.py, no stacktrace available (Error loading uno.py: python object raised an unknown exception (ImportError("No module named '_socket'",), traceback follows
<traceback object at 0x09E0D918>))
--- cut ---

I do not see this problem on Linux.
Comment 1 pierre-yves samyn 2013-06-04 13:59:45 UTC
Hello 

I confirm with windows 7 & windows XP with
Version: 4.1.0.0.beta1+
Build ID: 36b5efd733c68c67bb4a1b9489a775aed1fe98e
TinderBox: Win-x86_9-Voreppe, Branch:libreoffice-4-1, Time: 2013-05-31_17:43:42

These Wizards don't start
- Letter
- Fax
- Agenda
- Web Page 

I do not know if this is relevant but custom install does not offer python-uno bridge

Regards
Pierre-Yves
Comment 2 Commit Notification 2013-06-04 14:04:30 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=424e936fc095c676a24c04acdd1eb1fbb6a27bed

fdo#65305 fix python on win



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2013-06-04 14:09:18 UTC
ah it's a regression from b6bcbb675afedba0c47654dd78dc446dac0630d1 then
Comment 4 Commit Notification 2013-06-04 14:21:00 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8151270d24db4a3e813fbd76ead374e93c875da&h=libreoffice-4-1

fdo#65305 fix python on win


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Jacques Guilleron 2013-06-04 15:06:09 UTC
*** Bug 65307 has been marked as a duplicate of this bug. ***
Comment 6 pierre-yves samyn 2013-06-07 13:47:42 UTC
Hello

With Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6

These Wizards start
- Letter
- Fax
- Agenda

This Wizard *don't start*
- Web Page 

If you try to run this wizard, libreoffice not close directly

Steps to reproduce

1. File> Wizards> Web page

Expected result: the wizard starts
Actual result: the wizard don't start

2. File> Exit LibreOffice

Expected result: exit libreoffice
Actual result: libreoffice not closed

You have to redo file> Exit to close (or Ctrl+Q)

If you try to run x times the wizard, you need to do x+1 times "quit" to exit effectively.
 
Regards
Pierre-Yves
Comment 7 David Tardon 2013-06-07 13:52:40 UTC
Open a bug for that wizard, please. It is plainly a different problem from this one.
Comment 8 ribotb 2013-06-07 14:39:58 UTC
In beta2, Mail Merge E-mail test settings is OK.
And all the wizards start, but not Web page.

Bernard Ribot