Bug 65334 - SEARCHING in Notes (Comments) broken: cannot find a cell with searched text
Summary: SEARCHING in Notes (Comments) broken: cannot find a cell with searched text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: target:5.3.0 target:5.2.1
Keywords: bibisected, bisected, regression
: 46875 98532 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-04 08:30 UTC by Peter Draganov
Modified: 2016-10-25 18:38 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
example file (8.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-04 08:30 UTC, Peter Draganov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Draganov 2013-06-04 08:30:39 UTC
Created attachment 80268 [details]
example file

In Find & Replace dialog, when you select to search in Notes, Calc cannot find a cell with searched text. Just open the attached file and then search in notes for 1675. LibreOffice 3 has no such problems.
Comment 1 ign_christian 2013-06-09 02:04:58 UTC
I can confirm same behavior on LO 4.0.4.1 (Win7 32bit)
Comment 2 Peter Draganov 2014-07-28 16:24:20 UTC Comment hidden (no-value)
Comment 3 ign_christian 2014-08-15 03:29:47 UTC
Steps:
1. Open attached file
2. Find & Replace (Ctrl+H)
3. Click 'Other Options' > Search in "Notes"
4. In field 'Search for' type: 1675 > hit Enter > Yes

Issue: Cell A1 which contain the comment (notes) not selected

Still reproduced in LO 4.2.6.2 and 4.3.1.1, also in 3.6.7.2 under Ubuntu 12.04 x86

Not reproduced in LO 3.5.7.2
Comment 4 raal 2014-08-17 18:16:21 UTC
dea64da10b84bca6258ce739be79c32d90e28f15 is the first bad commit
commit dea64da10b84bca6258ce739be79c32d90e28f15
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Apr 26 02:40:08 2012 +0200

    source-hash-5af303c0cd4d46c459c6b90712843967d716c866
    
    commit 5af303c0cd4d46c459c6b90712843967d716c866
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Thu Mar 1 17:35:47 2012 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Thu Mar 1 17:35:47 2012 +0100
    
        -Werror=unused-variable

:100644 100644 30bbabe7f619a8a6d5bcd0ab0c1143e6354d6083 c352940df0e2d513f7f1c4e5744b95d63d4f18fb M	ccache.log
:100644 100644 8cfdf1cbbc71627c3e5f984d45e1fd61b78f17f0 cae646cc761327f27a5b4c44e5fb694d2b8c3e4f M	commitmsg
:100644 100644 5e8240e450c7dddaf8173ef7d9d881fb80f8dd97 baa2108091e01071bbe1877a797911fc416438c4 M	dev-install.log
:100644 100644 f2747a181d8e56dded5d54c719af73665219cdea 56f0b4b9e0598ec9ba50aa295103a9bd575657f8 M	make.log
:040000 040000 0a902f7d4e2923ec501ef6a482475f60943ce88a 64ad2f785665a03cb36af70fd4b16afe64dc97de M	opt

git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# good: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect good 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# good: [378efb6e51212a05d1bd4b85c916eec5753c1744] source-hash-d453788ac0476cc02b929b0907718ca771d6d956
git bisect good 378efb6e51212a05d1bd4b85c916eec5753c1744
# bad: [6fb876793ee949d0a22a542f7782be301d67ebb4] source-hash-4171bfefa788f539cf1f1ef327586e4319722b02
git bisect bad 6fb876793ee949d0a22a542f7782be301d67ebb4
# bad: [dea64da10b84bca6258ce739be79c32d90e28f15] source-hash-5af303c0cd4d46c459c6b90712843967d716c866
git bisect bad dea64da10b84bca6258ce739be79c32d90e28f15
# good: [5b5546ef8f29dfbd02c99de543cb1fe46d8600fb] source-hash-c581d33dec47a4c411a034482876543f6357d1e8
git bisect good 5b5546ef8f29dfbd02c99de543cb1fe46d8600fb
# good: [586a46cf017f9fd8667ed0d42841977deec37848] source-hash-b9b8ae8a484471ce067ad09dc96cad0d87285a6f
git bisect good 586a46cf017f9fd8667ed0d42841977deec37848
# first bad commit: [dea64da10b84bca6258ce739be79c32d90e28f15] source-hash-5af303c0cd4d46c459c6b90712843967d716c866
Comment 5 ign_christian 2014-08-27 13:08:09 UTC
*** Bug 46875 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Francis 2015-01-13 05:19:27 UTC
The ability to search in Calc notes seems to have broken across the below two commits.

Adding Cc: to markus.mohrhard@googlemail.com; Could you possibly have a look at this? Thanks


commit 33849f3fca52251eb7773802c78b6d8501921c37
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Tue Feb 28 03:21:10 2012 +0100

    remove mpNote: fix copy/paste

commit c06dbbe7594c2a0b5a5b19f8e183d9c421e6e094
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Thu Feb 23 23:36:49 2012 +0100

    remove mpNote from ScBaseCell
Comment 7 FS 2015-10-29 10:57:53 UTC
Still broken in 5.0.2.2 on Win 7... any news on this?
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:09:20 UTC Comment hidden (obsolete)
Comment 9 raal 2016-03-08 21:37:43 UTC
*** Bug 98532 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2016-07-27 10:53:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c84a219e3cc8d623826343f547ba8adacca6d56

Resolves: tdf#65334 cannot search in cell notes

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Eike Rathke 2016-07-27 12:04:43 UTC
Works only if the cell has content though, not if the note is on an otherwise empty cell.
Comment 12 Eike Rathke 2016-07-27 12:27:45 UTC
Taking over for that.
Comment 13 Commit Notification 2016-07-27 13:12:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2890a3fcdfcbf2447871ebc23db47864dd5b215&h=libreoffice-5-2

Resolves: tdf#65334 cannot search in cell notes

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2016-07-27 14:06:55 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f027c77c520adbdf8cec59e0484fc87b33cf203b

include empty cells if notes are searched, tdf#65334 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2016-07-27 14:35:46 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=09cc958dee93ad0ad2ab0d8cc9cc4c09e46c3653

use GetCellArea() when searching for notes, tdf#65334 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-07-27 16:19:44 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a02f7aa735c52f5d20df0e2a94cc06879cb3dfac

do not search in empty string if there is no note, tdf#65334 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-07-27 17:01:16 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=156590e7c0bf3c81f50b3d9862961e50010ea08a

use GetCellArea() also in SearchAll() and ReplaceAll(), tdf#65334 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-07-27 17:05:19 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d93284f65cf14fdf5e2520b474eb7383ca1d99e4

use HasCellNotes() when looping and searching for notes, tdf#65334 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2016-07-27 22:51:31 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f719263ae8dc44eabfba4654f9dbed92a9c5360

display the SearchAll() and ReplaceAll() results for notes, tdf#65334 related

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Eike Rathke 2016-07-27 23:31:49 UTC
Pending review https://gerrit.libreoffice.org/27603 for 5-2
Comment 21 Commit Notification 2016-07-28 09:24:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfa295f8a2f348c683ac28e55d5cd3c71b854f9d&h=libreoffice-5-2

handle notes on empty cells, display search results, tdf#65334 follow-up

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.