Bug Hunting Session
Bug 65340 - Presenting doesn't work on dual monitor system (fails to control Display2/external if Xinerama is disabled)
Summary: Presenting doesn't work on dual monitor system (fails to control Display2/ext...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2013-06-04 09:59 UTC by Johan Vromans
Modified: 2016-12-21 16:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Vromans 2013-06-04 09:59:52 UTC
On a system with a nVidia graphics card, nouveau driver, two monitors, Impress fails to control Display2 (external).
The video setup does have Xinerama disabled in /etc/X11/xorg.conf.
When Xinerama is enabled, all seems to work well.

How to reproduce:

Open a presentation.

Configure the presentation settings to use "Display2 (external)".

Start the presentation.

Display1 now shows the presentation control screen, while Display2 shows a white screen. When "exchange" is done, Display1 shows the presentation but Display2 remains white.

When the presentation settings are changed to use "Display1" the results are similar, Display2 always shows a white screen.

System details: Fedora 17, x86_64, all updates as of today.
NVidia GeForce 7600 GS graphics card.
X.Org X Server 1.12.4 + nouveau driver 0.0.16.
LibreOffice 4.0.0.0 beta1 (earlier versions of LO crashed in this setup due to bug #56583.
Comment 1 Johan Vromans 2013-06-23 19:35:18 UTC
The problem is still present in 4.1 RC1 and an absolute show stopper.
Comment 2 Jean-Baptiste Faure 2013-07-01 05:18:39 UTC
Please could you provide the following informations:
- the window manager you are using (Gnome, KDE, Xfce, other ?)
- did you try to disable Presenter Console in LO 4.1 (new option)? If you did, does it work? (so is the problem in Presenter Console or somewhere else?).

Side note: I have similar problem under Xubuntu 13.04 (Xfce window manager) but not with Gnome-shell or Unity. In my case the problem is in the window manager which does not manage correctly the second screen.

Thank you very much. JBF
Comment 3 Johan Vromans 2013-08-30 06:31:02 UTC
I use Fedora 17 with Gnome2 with OpenBox window manager.
As for the presentation console, I haven't been able to locate this setting. Where should it be?
Comment 4 Johan Vromans 2013-08-30 07:07:37 UTC
I switched to the metacity (Gnome standard) window manager, but it makes no difference.
Comment 5 Jean-Baptiste Faure 2013-08-30 19:37:43 UTC
(In reply to comment #3)
> I use Fedora 17 with Gnome2 with OpenBox window manager.
> As for the presentation console, I haven't been able to locate this setting.
> Where should it be?

In LibreOffice 4.1.2 : Menu Tools > Options > LibreOffice Impress > General > checkbox "Enable Presenter Console" in group Presentation

Best regards. JBF
Comment 6 Johan Vromans 2013-08-31 08:34:31 UTC
Enabling/disabling the presenter console does not solve it. As soon as the second screen is involved it becomes, and stays, blank until I terminate the presentation.
Comment 7 Owen Genat (retired) 2014-09-21 07:54:19 UTC
Summary amended for clarity.
Comment 8 QA Administrators 2015-10-14 19:58:09 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2016-11-08 11:38:24 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2016-11-11 09:39:43 UTC
Well, this bug report has never been independently confirmed. Set status back to UNCONFIRMED.

Best regards. JBF
Comment 11 tommy27 2016-12-21 15:36:24 UTC
please give an update of the bug status with latest LibO 5.2.3.3

set status to UNCONFIRMED if bug is still present or RESOLVED WORKSFORME if bug is gone.

NEEDINFO until then
Comment 12 tommy27 2016-12-21 16:05:37 UTC
the reported sent me an email telling this:

"I don't use Xinerama setup anymore so I cannot confirm either.

(I've mostly given up on OOo, I can't get into the bugzilla anymore).

-- Johan"

so I close this report as INSUFFICIENT DATA.