Download it now!
Bug 65350 - [Template manager] after saving a new template, the view is not refreshed, not sorted alphabetically, thus may be misleading users (see comment #3)
Summary: [Template manager] after saving a new template, the view is not refreshed, no...
Status: RESOLVED DUPLICATE of bug 74475
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-04 13:25 UTC by Dave
Modified: 2014-02-04 13:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Build number of the GB version of 4.0.3.3 (6.50 KB, image/gif)
2013-06-04 13:25 UTC, Dave
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2013-06-04 13:25:57 UTC
Created attachment 80290 [details]
Build number of the GB version of 4.0.3.3

Hello

Both in the German and GB versions after installing (Win 7-64)and changing paths, new, correctly saved templates are not visible when clicking on the Templates /My Templates buttons. However, going to My Templates and selecting "Import" seems to be a work-around.
This has not been a problem so far, maybe future builds like 4.1 should be checked for this bug.

Cheers,
Dave
Comment 1 Cor Nouws 2013-06-04 13:54:19 UTC
Hi DavE!

thanks for reporting.
I've some questions though, to get clear in detail what you did & see.

(In reply to comment #0)

> and changing paths, 

from what to what?

> new, correctly saved templates 

saved how?

> ...  are not visible when clicking on the Templates /My Templates buttons. 

You mean 'Templates /My Templates ' in the dialog File > New >Template, I guess?

> However, going to My Templates and selecting "Import" seems to be a
> work-around.

There you can import/find your templates?

> This has not been a problem so far, maybe future builds like 4.1 should be
> checked for this bug.


Short: is the problem that you cannot reach templates that are not saved via the Dialog "File > Save as template' ?
(see bug 61396) 

Cheers,
Cor
Comment 2 Dave 2013-06-04 16:58:31 UTC
On 04-Jun-2013 15:54, bugzilla-daemon@freedesktop.org wrote:
> Cor Nouws <mailto:cno@nouenoff.nl> changed bug 65350 
> <https://bugs.freedesktop.org/show_bug.cgi?id=65350>
> What 	Removed 	Added
> CC 		cno@nouenoff.nl
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=65350#c1> 
> on bug 65350 <https://bugs.freedesktop.org/show_bug.cgi?id=65350> from 
> Cor Nouws <mailto:cno@nouenoff.nl> *
> Hi DavE!
>
> thanks for reporting.
> I've some questions though, to get clear in detail what you did & see.
>
> (In reply tocomment #0  <show_bug.cgi?id=65350#c0>)
>
> > and changing paths,
>
> from what to what?
from the default c:\users, etc to D:\All 
Data\LibreOfficeSystemFiles\Template
>
> > new, correctly saved templates
>
> saved how?
1 ) Save as Template
2) Save as... .ott
> > ...  are not visible when clicking on the Templates /My Templates buttons.
>
> You mean 'Templates /My Templates ' in the dialog File > New >Template, I
> guess?
Yes
> > However, going to My Templates and selecting "Import" seems to be a
> > work-around.
>
> There you can import/find your templates?
Yes
> > This has not been a problem so far, maybe future builds like 4.1 should be
> > checked for this bug.
>
>
> Short: is the problem that you cannot reach templates that are not saved via
> the Dialog "File > Save as template' ?
> (seebug 61396  <show_bug.cgi?id=61396>)
No, either way it doesn't show the new templates. However, I have just 
fooled about with making templates to check my experiences and have 
found out that
a) new templates don't seem to be automatically sorted alphabetically
b) there is a refresh button behind/under the cog wheel settings button 
in the template manager. Use this refresh function the template manager 
then has all the templates.

My suggestions for further work are:
a) make the refresh function automatic when either save procedure is used
b) make the alphabetical sorting absolutely automatic

As far as I can tell from V.3.0 on, these functions were always 
automatic, and somehow got turned off in 4.0.3.3

I hope you can use my information. If you need any further info or 
testing, just mail me.

Thanks a lot,
Dave
> Cheers,
> Cor
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Cor Nouws 2013-10-20 19:39:11 UTC
Hi Dave,

(In reply to comment #2)
> ... However, I have just 
> fooled about with making templates to check my experiences and have 
> found out that
> a) new templates don't seem to be automatically sorted alphabetically
> b) there is a refresh button behind/under the cog wheel settings button 
> in the template manager. Use this refresh function the template manager 
> then has all the templates.
> 
> My suggestions for further work are:
> a) make the refresh function automatic when either save procedure is used
> b) make the alphabetical sorting absolutely automatic

Thanks, that is clear.

To reproduce:
- Save template with name AA_foo to folder with many templates
- Looks as it template is not there: it's far at the bottom.
Comment 4 Cor Nouws 2014-02-03 21:17:23 UTC
I guess this will be resolved if bug 74475 is fixed...
Comment 5 Jorendc 2014-02-04 13:45:09 UTC
Lets mark this one as dupe of bug 74475.

We discussed this behavior on the UX hackfest right now. The correct behavior should be: close the dialog after you successfully saved a template (which is suggested in bug 74475). This is the same behavior as saving as a regular file.

Lets fix that bug, so this bug is 'obsolete' because we will not return to this dialog afterwards.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 74475 ***