Bug 61396 - FILEOPEN: [Template Manager]Possibility to edit a template that is not in the repository, is lacking
Summary: FILEOPEN: [Template Manager]Possibility to edit a template that is not in the...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: medium major
Assignee: Akshay Deep
QA Contact:
URL:
Whiteboard: BSA target:5.3.0 target:5.2.0.1
Keywords: bibisectNotNeeded, regression
: 61465 65408 (view as bug list)
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2013-02-24 12:06 UTC by pierre-yves samyn
Modified: 2016-10-18 13:00 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot FileOpenEditTemplate.png (8.23 KB, image/png)
2013-02-27 08:11 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-02-24 12:06:13 UTC
Hello

The new template manager does not allow you to edit a model not listed in the directory models (you need to import first).

It has the advantage of being "structuring" and encouraging good uses.

The downside is that the "File> Save" command allowed (and still allows) to save where you want as "Template" (select the .ott type for example) and it becomes impossible to edit these documents.

My suggestion would be to change the File> Open> Type: Model xxx ODF for it opens the template.

In other words:
1. File> Open> Select a .ot(tsg...) file creates a new document (current behavior)
2. File> Open> Select a .ot(tsg...) file then  select type: "ODF model xxx" edits the model.

This would be consistent with what is done for File> Save.
It does not add menu entry.
It does not change the template manager
It provides a utility to File> Open> Type: Model, currently overlap with File> Open
This allows to "recover" functionality lost with the new manager.

Regards
Pierre-Yves
Operating System: All
Version: 4.0.1.1 rc
Comment 1 Joel Madero 2013-02-26 18:04:56 UTC
Getting Astron involved.

Astron - apologies but you are the only one that I know of who really knows this stuff well.
Comment 2 Stefan Knorr (astron) 2013-02-26 20:05:07 UTC
@Joel: Happy to oblige, even if my understanding of template stuff is actually rather cursory.

@Pierre-Yves, I take it, you use "model" in the meaning of "template"? That confused me a bit...

So, as far as I understand you, you want an extra tick box in the Open dialogue that allows switching between
  (1) opening the template and
  (2) opening a new document based on the template.
Is that correct?


* I would assume the second point is likely what user want in the majority of
  cases
* It seems reasonably simple to just overwrite the template by using Save As...
  in the end to achieve what you'd intend by going the first route.
Comment 3 pierre-yves samyn 2013-02-27 08:10:29 UTC
Hello

Thank you for your response

(In reply to comment #2)
 
> @Pierre-Yves, I take it, you use "model" in the meaning of "template"? That
> confused me a bit...

Yes "model" means "template", sorry for my bad english... :(

> So, as far as I understand you, you want an extra tick box in the Open
> dialogue that allows switching between
>   (1) opening the template and
>   (2) opening a new document based on the template.
> Is that correct?

No additional check box is needed: I suggest that the choice of document type makes the difference. 

1.If the user explicitly chooses "template" (see screenshot "FileOpenEditTemplate.png), "File>  Open" edits the template (new behaviour)
2.Otherwise "File>  Open" creates a new document based on the template (current behaviour)

As I said before:
*This would be consistent with what is done for File> Save.
*It does not add menu entry or anything else
*It does not change the template manager
*It provides a utility to File> Open> Type: Model, currently overlap with File> Open
*This allows to "recover" functionality lost with the new manager.


> * I would assume the second point is likely what user want in the majority of
>   cases

I do not agree with that: if the user specifies the type "Template", he wants to edit the template.

As an example: when you want to open a text file (.txt) in the spreadsheet, you select the filter in the list, otherwise it opens in Writer.
It would not be acceptable that the choice of filter would not be respected.
Currently, choose the "template" filter or not makes no difference.


> * It seems reasonably simple to just overwrite the template by using Save
> As...

The software allows me to create something, does not allow me to change it. I need to create a copy and replace the original. It is indeed possible ... but it is a workaround.

I'm not sure that we should be satisfied ...

Regards
Pierre-Yves
Comment 4 pierre-yves samyn 2013-02-27 08:11:27 UTC
Created attachment 75620 [details]
Screenshot FileOpenEditTemplate.png
Comment 5 Cor Nouws 2013-03-02 23:01:29 UTC
*** Bug 61465 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2013-03-02 23:03:12 UTC
comment from dup:
 Cor Nouws 2013-02-25 22:21:28 UTC

In version 3.6.x and previous you could choose
 File > Template > Edit
and then browse to any location to edit a template.

In 4.0.x this is no longer possible.

Work arounds exist. But I do not have an office suite to use work arounds ;-)
Comment 7 Cor Nouws 2013-03-14 23:02:27 UTC
What about adding the option that Shift+Open in the file open dialog opens the template as such, in stead of making a new document derived from the template?
Comment 8 pierre-yves samyn 2013-03-15 08:27:25 UTC
Hello

(In reply to comment #7)
> What about adding the option that Shift+Open in the file open dialog opens
> the template...

I doubt that it is very intuitive.

Why add a feature when there is *already* one, as I said: selection of the type "template" in the Open dialog ?

By doing this the user makes clear its intention to open the template.

Users are accustomed to using this list to change the default opening.
This is the same list that they used to save as "template".

I'm always surprised that the choice "template" has no effect when opening and it creates a new document. It is almost a bug to me.

Sorry but it seems so simple to me (I'm not talking about ease of implementation) that I do not understand why any of the intervenants in this thread gives its opinion on this proposal?

Best regards
Pierre-Yves
Comment 9 Mark Nienberg 2013-03-25 19:39:38 UTC
In my organization we also need to edit templates that are not within the template directory structure, so are not available through the Template Manager. v4.0 has confused us with the disappearance of the File>Templates menu, particularly since it is still mentioned in the Help menu. I don't have any preference for how to add this ability back to the program, but we definitely need it.
Comment 10 Stefan Knorr (astron) 2013-04-04 13:57:55 UTC
Long time no answer...

(In reply to comment #8)
> Why add a feature when there is *already* one, as I said: selection of the
> type "template" in the Open dialog ?
> 
> By doing this the user makes clear its intention to open the template.

No, not at all (at least I can't see any reason why filtering for templates would mean that a user wants to edit said template). All the format picker does and should do in this case is filter out unwanted file formats.

To me, your solutions seems rather unintuitive, because it is hard to trigger and rather oblique to the user.


> Users are accustomed to using this list to change the default opening.
> This is the same list that they used to save as "template".

Right, but:
a) what you say goes only for saving
b) you can still override that choice by adding a file extension and quotes around the file name (or at least that's the way it is in notepad.exe, not completely sure about LibO)


@Cor, comment 7:
Shift-Click is an interesting idea, but I see two problems with it:
* It's not particularly discoverable either (though that doesn't disqualify it as a secondary way to access the function)
* Shift-Click is usually associated with multiple selections in this context, as is Ctrl-Click, so I am a bit dubious about whether it would be confusing to have two different interpretations of Shift-Click so close to each
Comment 11 pierre-yves samyn 2013-04-04 17:16:42 UTC
Hello

(In reply to comment #10)
> Long time no answer...

and so thank you for your answer even if I do not share your point of view :)

> No, not at all (at least I can't see any reason why filtering for templates
> would mean that a user wants to edit said template). 

Yes, definitely for me :)

As I said in comment 3 when you want to open a text file (.txt) in the spreadsheet, you select the filter in the list, otherwise it opens in Writer.

Select the file's type *changes* the default open mode for the *same* file.

> > Users are accustomed to using this list to change the default opening.
> > This is the same list that they used to save as "template".
> 
> Right, but:
> a) what you say goes only for saving

Up to now...

Best regards
Pierre-Yves
Comment 12 Stefan Knorr (astron) 2013-04-04 17:44:25 UTC
Hi Pierre-Yves (comment #11),

> As I said in comment 3 when you want to open a text file (.txt) in the
> spreadsheet, you select the filter in the list, otherwise it opens in Writer.

Hm, I can't reproduce that on 4.0 on Linux ... .txt files only show up when I select "Text Documents" as the filter. Or is that just how you'd wish it to work?

Oh, btw, I forgot what would think would be the best solution for it: The new Template Manager contains a cogwheel/Action menu, which could be extended to look like this:

  [ ] Reverse sort order
      Refresh
  ---------------------------
      Edit external template

(I guess the wording could be shorter, though. Ideas welcome.)

Additionally, something like Cor's idea (comment #7) could be implemented, although I don't know if either Ctrl or Shift are good modifiers (see comment above).

(CC'ing Cedric.)
Comment 13 pierre-yves samyn 2013-04-05 08:09:08 UTC
Hi

(In reply to comment #12)
 > Hm, I can't reproduce that on 4.0 on Linux ... .txt files only show up when
> I select "Text Documents" as the filter. 

You're right, I was not specific enough.

Steps to reproduce:

1. File> Open 
Filters: All files (*.*) is selected, so you can see and...
2. Select your .txt file
3. Click the drop down list, down to the spreadsheet filters and 
4. Select Text (*.csv)
5. Click Open

The spreadsheet wizard starts to open the file in the spreadsheet.


> new Template Manager contains a cogwheel/Action menu, which could be
> extended to look like this:
> 
>   [ ] Reverse sort order
>       Refresh
>   ---------------------------
>       Edit external template

This could be a solution

> Additionally, something like Cor's idea (comment #7) could be implemented,
> although I don't know if either Ctrl or Shift are good modifiers (see
> comment above).

To be honest I do not like this type of solution. Microsoft used it (I do not know if this is still the case) to change for example the Close menu (changed to "Close All"). My experience as trainer and support  tells me that this feature was not intuitive and therefore unknown.  I may be wrong ...

Best regards
Pierre-Yves
Comment 14 Cor Nouws 2013-06-05 10:49:19 UTC
*** Bug 65408 has been marked as a duplicate of this bug. ***
Comment 15 Mark Nienberg 2013-06-12 22:52:22 UTC
How about just keeping it simple and adding a menu item like this
File > Edit Template...

It could go just below the existing
File > Save As Template...

We have already implemented something similar in our office using Basic macros. The loss of the ability to edit templates in random locations was causing lots of headaches.
Comment 16 Cor Nouws 2013-06-13 07:19:57 UTC
one can hardly classify this as an enhancement with dry eyes.
Set as major bug.
Comment 17 Cédric Bosdonnat 2014-01-20 09:00:38 UTC
Restricted my LibreOffice hacking area
Comment 18 Cor Nouws 2014-02-04 14:52:34 UTC
After discussion at the UX hackfest, solution choosen in to add it to the menu

 File > Templates 
that then will have the entries:

   Manage..
   Save as Template
   Open for Editing..
Comment 19 pierre-yves samyn 2014-02-17 10:02:29 UTC
Hello

(In reply to comment #18)
> After discussion at the UX hackfest, solution choosen in to add it to the
> menu File > Templates 

It would be ok for me
This feature is required and expected by users...

Thank you
Regards
Pierre-Yves
Comment 20 Robinson Tryon (qubit) 2015-01-19 06:49:33 UTC
(In reply to Cor Nouws from comment #6)
> In version 3.6.x and previous you could choose
>  File > Template > Edit
> and then browse to any location to edit a template.
> 
> In 4.0.x this is no longer possible.

Sounds like change is in the bibisectable range:
Whiteboard -> bibisectRequest

But it's unclear to me if bibisecting would be directly applicable here.

Cor: Please feel free to change bibisectRequest -> bibisectUnhelpful , if appropriate.
Comment 21 Cor Nouws 2015-01-19 09:19:56 UTC
(In reply to Robinson Tryon (qubit) from comment #20)

> Cor: Please feel free to change bibisectRequest -> bibisectUnhelpful , if
> appropriate.

Hi Robinson: I'll do so.
It's just a new but incomplete implementation of the template manager.
Comment 22 Cor Nouws 2015-01-19 09:21:21 UTC
Looking at various other stuff that is marked as MAB, IMNSHO this one should be there too...
Comment 23 Robinson Tryon (qubit) 2015-12-14 05:54:08 UTC
Migrating Whiteboard tags to Keywords: (bibisectUnhelpful -> bibisectNotNeeded)
[NinjaEdit]
Comment 24 Regina Henschel 2016-01-05 17:22:57 UTC
The command .uno:OpenTemplate still works to open a template for editing from arbitrary place. You can customize the File|Templates menu and add that command. The command is in Category "Templates", Command "Edit".

So I think, it is an "easy hack".

I have tried it in Version: 5.2.0.0.alpha0+
Build ID: e413549dc8b5669a806eeabc30c7d6f92723a882
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-28_23:26:49
Locale: de-DE (de_DE)
Comment 25 Cor Nouws 2016-06-11 20:09:10 UTC
Hi Regina,


(In reply to Regina Henschel from comment #24)
> The command .uno:OpenTemplate still works to open a template for editing
> ...

only reading this now :|
thanks! useful info.

> So I think, it is an "easy hack".

Indeed.

@Akshay: if you are focusing on other stuff first, I could do this if you prefer. Getting it in 5.2 before string freeze.

Ciao - Cor
Comment 26 Akshay Deep 2016-06-11 20:18:04 UTC
> @Akshay: if you are focusing on other stuff first, I could do this if you
> prefer. Getting it in 5.2 before string freeze.
> 
> Ciao - Cor

Hi, I've the patch up of gerrit already.. 

https://gerrit.libreoffice.org/#/c/26179/

I will make some small changes and will merge on monday. Yes.. It will be there in master and 5.2. ( I guess the deadline for 5.2 is 20 june)
Comment 27 Cor Nouws 2016-06-11 20:31:30 UTC
(In reply to Akshay Deep from comment #26)

> Hi, I've the patch up of gerrit already.. 

Ah, thanks :)
Comment 28 Commit Notification 2016-06-15 15:55:07 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=384c75b7e8b50a64a1c0e8fd1ffef1350e2522d2

tdf#61396 Possibility to edit a template not in Template Repository

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2016-06-15 16:11:34 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c8e75854bf98c01b5762734cb6bbc9e56f0d15df&h=libreoffice-5-2

tdf#61396 Possibility to edit a template not in Template Repository

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 pierre-yves samyn 2016-09-23 07:18:02 UTC
Hi

(In reply to Commit Notification from comment #29)
> Akshay Deep committed a patch related to this issue.
> It has been pushed to "libreoffice-5-2":
> 

Verified on windows 7/64 & Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: fr-FR (fr_FR)

Sorry for the delay and thank you :)

Regards
Pierre-Yves