Bug 65400 - FILESAVE: DOCX export causes character shading color to change
Summary: FILESAVE: DOCX export causes character shading color to change
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: low major
Assignee: Adam CloudOn
QA Contact: Jorendc
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-05 08:20 UTC by Adam CloudOn
Modified: 2014-02-17 08:41 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
DOCX containing character shading (11.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-05 08:20 UTC, Adam CloudOn
Details
Another DOCX containing 'Character Shaded' text and normal shaded text (11.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-24 14:26 UTC, Adam CloudOn
Details
Word for Mac 2011; left original, right roundtripped (223.39 KB, image/png)
2014-02-14 15:57 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-06-05 08:20:00 UTC
Created attachment 80325 [details]
DOCX containing character shading

Problem description: 
When a DOCX that has character shading is loaded to LO - the character shading color is dark-gray (while in Word it is light-gray). this is an import issue already reported here:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=65399

When saving the DOCX back to a NEW.DOCX and opening it in Word - the character shading remains the dark-gray, instead of the original light-gray that was in the original DOCX (information is changed).

Steps to reproduce:
1. Open the attached DOCX in LO
2. Save as a NEW.DOCX
3. Open the NEW.DOCX in Word
4. The character shading is now dark-gray instead of light-gray in the original DOCX.

Current behavior:
LO exports to the DOCX the changed dark-gray color as the character's shade.

Expected behavior:
LO should export the light-gray color to DOCX and not change the original shading color.
              
Operating System: Windows 8
Version: 4.0.3.3 release
Comment 1 Jorendc 2013-06-08 09:13:52 UTC
I can confirm that using Mac OSX 10.8.3 with LibreOffice 4.1.0 beta 2, with Word for Mac 2011.

Kind regards,
Joren
Comment 2 Adam CloudOn 2013-06-24 14:26:27 UTC
Created attachment 81344 [details]
Another DOCX containing 'Character Shaded' text and normal shaded text
Comment 3 Jorendc 2014-02-14 15:56:42 UTC
@Adam: this one looks fixed to me too. You mind retesting my RESOLVED WORKSFORME's for sure :-)? /me doesn't know the backend 100% well

Tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: a315454f349469923490e4116806ee19263849b8

Kind regards,
Joren
Comment 4 Jorendc 2014-02-14 15:57:13 UTC
Created attachment 94077 [details]
Word for Mac 2011; left original, right roundtripped
Comment 5 Adam CloudOn 2014-02-16 09:07:33 UTC
(In reply to comment #3)
> @Adam: this one looks fixed to me too. You mind retesting my RESOLVED
> WORKSFORME's for sure :-)? /me doesn't know the backend 100% well
> 
> Tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
> Build ID: a315454f349469923490e4116806ee19263849b8
> 
> Kind regards,
> Joren

@Joren
Not sure what you want me to test exactly :)
Do you want me to simply RT with my local build and check it is fixed?
Comment 6 Jorendc 2014-02-16 14:40:26 UTC
(In reply to comment #5)
> @Joren
> Not sure what you want me to test exactly :)
> Do you want me to simply RT with my local build and check it is fixed?

Yes, if you can and would like to ;-). I did close some of your bugs lately, because they look fixed to me. You are an expert :), so I'm not willing to blindly mark your bugs as 'resolved worksforme' ;-).

So, in other words: please if you doubt this is fixed, feel free to retest for sure.
Comment 7 Adam CloudOn 2014-02-17 08:41:23 UTC
just verified the XML of the exported DOCX.
works for me, too.