Bug 65414 - Arabic: wrong render for Arabic text in impress and calc on text direction LTR
Summary: Arabic: wrong render for Arabic text in impress and calc on text direction LTR
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 65562
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 12:23 UTC by Faisal Menawer
Modified: 2013-06-11 08:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bug screenshot (2.79 KB, image/png)
2013-06-05 12:25 UTC, Faisal Menawer
Details
screenshot using KacstBook (2.41 KB, image/png)
2013-06-05 13:42 UTC, Faisal Menawer
Details
Screenshot using amiri (1.95 KB, image/png)
2013-06-05 14:04 UTC, Faisal Menawer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Faisal Menawer 2013-06-05 12:23:21 UTC
There an wrong rendering for Arabic text in impress and calc

step to reproduce:
1- open impress or calc
2- write something in arabic with LTR text direction.

there are wrong rendering. but when change the text direction to 
RTL it look good.
Comment 1 Faisal Menawer 2013-06-05 12:25:30 UTC
Created attachment 80341 [details]
bug screenshot
Comment 2 Faisal Menawer 2013-06-05 12:36:11 UTC
the bug appear on some fonts like Lohit Hindi
Comment 3 Khaled Hosny 2013-06-05 12:54:20 UTC
That font looks like Free Serif, could ypu check if the issue persists of you select that font explicitely? If so, please provide the version of the font.
Comment 4 Faisal Menawer 2013-06-05 13:42:40 UTC
Created attachment 80345 [details]
screenshot using KacstBook
Comment 5 Faisal Menawer 2013-06-05 14:04:24 UTC
Created attachment 80346 [details]
Screenshot using amiri

when you using other fonts it will be add more kashida on LTR than RTL.
Comment 6 Ahmad Harthi 2013-06-10 06:01:17 UTC
Confirmed on LO4.1 Beta
Comment 7 Petr Mladek 2013-06-11 08:50:47 UTC
We have reverted the fix for the bug #60533, so this should work again.