Bug 65453 - : Installed 'variant' Font not recognised & used by LO Writer
Summary: : Installed 'variant' Font not recognised & used by LO Writer
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Fonts
  Show dependency treegraph
 
Reported: 2013-06-06 11:18 UTC by Jeremy
Modified: 2019-06-27 14:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document in .odt format to show problem (13.82 KB, application/vnd.oasis.opendocument.text)
2013-06-11 09:42 UTC, Jeremy
Details
Same Document in .doc (Word) format (12.50 KB, application/msword)
2013-06-11 09:44 UTC, Jeremy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy 2013-06-06 11:18:19 UTC
Problem description: 

Having both normal (e.g. PT Sans) and 'variant' (e.g. PT Sans Bold) versions of a font installed (as per Control Panel > Fonts), the 'variant' version is not recognised is not recognised as being installed.
When part of a document is specified as using that font (as per drop down menu) default font selected by LO is used instead. Specifying it in font selection dialogue (for Character style, Find & Replace by Format, etc.) leads to 'This font is not installed...' message 
   
Steps to reproduce:
1. Choose appropriate font, with bold (or other) variant.
2. Type in variant font name manually, in font selection box in dialogue, or in formatting tool bar (for a selection)   

Current behaviour:
Variant font is not recognised as installed, or used

Expected behaviour:
Variant font should be recognised as installed and used, either directly or after conversion to normal font with (e.g.) Bold attribute applied.  

              
Operating System: Windows XP
Version: 3.6.6.2 release
Comment 1 Luuk 2013-06-08 12:31:38 UTC
I think it should not be possible to choose a font name that is not in the list of installed fonts. Because now you can pick 'any' font....

This is also possible in LO 4.0.3.3 on Windows7
Comment 2 Jeremy 2013-06-09 23:52:00 UTC
Ability to specify font manually (by typing in name, regardless of it being installed or not), rather than just select from list is only of relevance to this issue in creating test case to demonstrate system behaviour (and is not of itself an issue - there are perfectly valid (if unusual) reasons for doing so).

Testing after upgrading LO to 4.0.3.3 (still Windows XP) shows same behaviour.   

Problem originally showed up to me when:
1) Received document (.doc file) from colleague, using PT Sans fonts (which I did not have). Whole document had seen in substituted, seriffed, font, so obviously wrong: but not unexpected behaviour OO/LO have long done this for uninstalled fonts.
2) Obtained and installed PT Sans font - including both PT Sans and PT Sans Bold fonts (as .ttf files and entries in Windows Control Panel Display). Sections of document specified as PT Sans now ok; sections in PT Sans Bold still in substitute font => this issue (as font now installed, so should be used)

Determination that font name ("PT Sans Bold") could be entered manually, and that in some places gave 'not installed' message (although Windows says it is), came later in trying things out. 
  
Also found same behaviour with other installed fonts, e.g. Arial & Arial Bold.
Comment 3 Jeremy 2013-06-11 09:42:50 UTC
Created attachment 80672 [details]
Sample Document in .odt format to show problem

Most of document is in PT Sans family font - see included comment.
Comment 4 Jeremy 2013-06-11 09:44:34 UTC
Created attachment 80673 [details]
Same Document in .doc (Word) format
Comment 5 QA Administrators 2015-03-16 23:52:09 UTC Comment hidden (obsolete)
Comment 6 Jeremy 2015-03-19 19:03:27 UTC
Bug still present, in LO 4.4.1 on Windows XP, and on Windows 7.
Comment 7 tommy27 2016-04-16 07:23:01 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-05-22 13:22:40 UTC Comment hidden (obsolete)
Comment 9 Christian Lehmann 2019-06-27 14:44:42 UTC
LO 6.2.4.2 installed on Kubuntu 18.04 and in a virtual machine of Lubuntu 16.04.

My ODT file uses Cambria (TTF) as the default and only font.
Cambria is installed on both flavors of Ubuntu.
It is recognized by LO on Kubuntu and displays well.
On Lubuntu, it throws the message "This font has not been installed ...", and consequently it displays wrongly.
There is a large selection of directories called 'fonts' on the operating system. I have installed the Cambria fonts in all of them, run 'sudo fc-cache -f -v' and got the response that Cambria is installed. The question is why LO Writer does not recognize this, or rather, what I have to do to make LO Writer see the installed fonts.
The problem has also been discussed on
https://askubuntu.com/questions/1005777/restore-locally-installed-fonts-after-libreoffice-upgrade
and there it appeared to be solved. But it is definitely not solved on all flavors of Ubuntu.