Bug 65594 - EDITING: Crash when trying to remove a named bitmap
Summary: EDITING: Crash when trying to remove a named bitmap
Status: RESOLVED DUPLICATE of bug 64279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-06-10 06:41 UTC by dany franck
Modified: 2013-06-20 21:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error messages and delphi code (135.42 KB, application/vnd.oasis.opendocument.text)
2013-06-10 06:41 UTC, dany franck
Details
The used model with the bitmap (60.79 KB, application/vnd.oasis.opendocument.text-template)
2013-06-10 06:44 UTC, dany franck
Details
Attachment contains a macro reproducing the problem (58.02 KB, application/vnd.oasis.opendocument.text)
2013-06-17 07:21 UTC, dany franck
Details
Contains a macro (supprimerimage) producing the crash (61.13 KB, application/vnd.oasis.opendocument.text)
2013-06-18 05:53 UTC, dany franck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dany franck 2013-06-10 06:41:41 UTC
Created attachment 80598 [details]
Error messages and delphi code

Problem description:

A delphi programm pilots LO via DCOM. It opens a model with text and three bitmaps. It happens that one of the bitmaps had to be removed in the document. In this version, LO crashes on the command page.remove(object) (also in 4.1b1). 
The delphi code and then messages are reproduced inthe first attachment. The model is the second attachment.
All works fine in previous versions.

              
Operating System: Windows 7
Version: 4.0.4.1 rc
Last worked in: 4.0.3.3 release
Comment 1 dany franck 2013-06-10 06:44:30 UTC
Created attachment 80601 [details]
The used model with the bitmap
Comment 2 dany franck 2013-06-17 07:21:37 UTC
Created attachment 80933 [details]
Attachment contains a macro reproducing the problem

The supposed bug was detected with a program under DCOM. The crash can be reproduced with a macro.
The document contains the macro SupprimerImage. The crash happens on maPage.remove(monImage)
Comment 3 dany franck 2013-06-18 05:53:13 UTC
Created attachment 80982 [details]
Contains a macro (supprimerimage) producing the crash

The macro caused the same crash as the Dcom program. The crash happens on the removal of one of the bitmaps.
Comment 4 Michael Stahl (CIB) 2013-06-20 21:28:11 UTC
fixed in LO 4.0.5.1 by commit 7096efde95732b613dfa76df61a343b96ec6f979

... so this problem did not just affect ReportBuilder but ordinary Writer documents too...

*** This bug has been marked as a duplicate of bug 64279 ***