Bug 65617 - Liberation Sans/Serif/Mono Regular get displayed as a generic monospace font (Courier New) on Windows XP 64
Summary: Liberation Sans/Serif/Mono Regular get displayed as a generic monospace font ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-10 18:31 UTC by kookoo
Modified: 2018-09-07 07:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
font preview for Liberation Sans Regular (15.20 KB, image/png)
2013-06-10 18:32 UTC, kookoo
Details
font preview for Liberation Sans Bold (66.69 KB, image/png)
2013-06-10 18:32 UTC, kookoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kookoo 2013-06-10 18:31:38 UTC
I am using Libreoffice 4.0.3.3 on Windows XP x64.

In Libreoffice, Liberation Sans/SansNarrow/Serif/Mono fonts do not display correctly when neither bold or italic is used. They get displayed as a generic monospace font (Courier New). Bold or italic versions are fine.

In the Windows font preview, the Bold/Italic/BoldItalic version display fine, but the Regular version displays a blank page (metadata is not displayed, and even the "(Truetype)" suffix is missing).

This is certainly related to Bug 62764.
Comment 1 kookoo 2013-06-10 18:32:16 UTC
Created attachment 80634 [details]
font preview for Liberation Sans Regular
Comment 2 kookoo 2013-06-10 18:32:35 UTC
Created attachment 80635 [details]
font preview for Liberation Sans Bold
Comment 3 Dennis Grunert 2013-09-06 13:22:46 UTC
I can confirm this bug on my Windows 8 machine after updating from Libreoffice 3.6 (normal font display of Liberation sans) to 4.0. Now everything looks monospace and breaks my documents, but Liberation Sans is still displayed as selected font, so it is a displaying problem.

Since this is a show stopper and breaks fundamental user experience, I triage this as major.
Comment 4 Dennis Grunert 2013-09-06 13:24:50 UTC
@kookoo: Your first screenshot doesn't show much of a font preview (almost everything on this image is white), so maybe this is part of the problem.
Comment 5 Dennis Grunert 2013-09-10 12:43:32 UTC
After some more testing, it seems this is _not_ a Libreoffice bug but a bug between the Liberation font and Windows. It's because the wrong displaying also occurs, when one changes the font in the Windows Editor to one of the Liberation fonts, so it's not Libreoffice specific, but appears one updates/installs Libreoffice.

Fix: Install the newest version of the Liberation font 2.00 from https://fedorahosted.org/liberation-fonts/. Windows needs a restart, if you only copy the ttf's to %windir&\fonts instead of installing them.

This is bug report should still be kept open, since Libreoffice should not distribute a font version with bugs, so this should be fixed in the next minor release.
Comment 6 Dennis Grunert 2013-11-06 19:57:09 UTC
5 months after reporting this reproducible bug and 2 months after a fix was suggested (distributing the Windows version of LO with a newer Libreation font version) no responsible maintainer seems to care.
Comment 7 Maxim Monastirsky 2013-11-07 06:59:21 UTC
(In reply to comment #6)
> 5 months after reporting this reproducible bug and 2 months after a fix was
> suggested (distributing the Windows version of LO with a newer Libreation
> font version) no responsible maintainer seems to care.
Hi,
The problem is that 4.0\4.1 *does* come with version 2.0 of liberation fonts. Just checked with 4.0 & 4.1.3 installers, and the included fonts are bit-to-bit identical to the ones from the official Liberation fonts site.
Comment 8 Dennis Grunert 2013-11-07 18:27:35 UTC
(In reply to comment #7)
> The problem is that 4.0\4.1 *does* come with version 2.0 of liberation
> fonts. Just checked with 4.0 & 4.1.3 installers, and the included fonts are
> bit-to-bit identical to the ones from the official Liberation fonts site.

As a fact, an upgrade from 3.6 to 4.0 breaks it (but apparently not for all users) and installing the font manually repairs it. What didn't repair it, was downgrading and reupgrading, so something with the installer seems to be wrong. I don't know that stuff, but on Windows you need to kind of register a new font? Did 3.6 use another versions of the font?
Comment 9 Maxim Monastirsky 2013-11-07 20:08:52 UTC
(In reply to comment #8)
>Did 3.6 use another versions of the font?
Indeed, 3.6 came with version 2.00.0 of the fonts, while 4.0 & 4.1 come with 2.00.1.
Comment 10 Maxim Monastirsky 2013-11-07 21:26:15 UTC
I can't reproduce that bug with a clean installation of Windows 7 (32-bit). First I installed 3.6.7, then upgraded to 4.0.3. The installer successfully replaced old fonts with the new ones. The fonts are working perfectly after that.

Anyway, would be great if you could test it with the latest version of LibreOffice (4.1.3).
Comment 11 Dennis Grunert 2013-11-07 21:34:57 UTC
(In reply to comment #10)
> I can't reproduce that bug with a clean installation of Windows 7 (32-bit).
The initial bug reporter used Windows XP and I had this bug only on Windows 8 (two Windows 7 machines hadn't this issue, I upgraded them on the same day). Can you try to reproduce it with XP or 8?
Comment 12 Maxim Monastirsky 2013-11-07 22:28:28 UTC
(In reply to comment #11)
>Can you try to reproduce it with XP or 8?
Can't reproduce also with XP SP3 (32-bit). Don't have XP 64-bit or Windows 8.
Comment 13 QA Administrators 2015-04-19 03:20:10 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2015-06-15 10:27:14 UTC
Never had this problem on Win. Issue seems obsolete now (3.6 - 4.0).
Setting to WFM.
If the reporter still suffers from this, they can set back to NEW.
Comment 15 Kerry Hjertaas 2018-09-06 21:35:21 UTC
This issue seems to be back for me now, in LibreOffice 6.1.0.3 (x64).

About LibreOffice screens shows this:

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 8; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded


This was working prior to my LibreOffice install updating itself to the latest version on September 4th.  Liberation Sans, Liberation Sans Narrow and Liberation Serif all look like Liberation Mono.
Comment 16 V Stuart Foote 2018-09-07 00:14:19 UTC
(In reply to Kerry Hjertaas from comment #15)
> This issue seems to be back for me now, in LibreOffice 6.1.0.3 (x64).
> 
> About LibreOffice screens shows this:
> 
> Version: 6.1.0.3 (x64)
> Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
> CPU threads: 8; OS: Windows 6.1; UI render: default; 
> Locale: en-US (en_US); Calc: group threaded
> 
> 
> This was working prior to my LibreOffice install updating itself to the
> latest version on September 4th.  Liberation Sans, Liberation Sans Narrow
> and Liberation Serif all look like Liberation Mono.

New issue please. And, what is needed is a verbose installation log.

i.e. from a Command prompt "Run as Administrator" command line:

msiexec.exe /i LibreOffice_6.1.0.3_Win_x64.msi /L*v lo610installLog.txt

Then, if issue actually is repeated, zip the logfile and attach to a new BZ issue.
Comment 17 Buovjaga 2018-09-07 07:33:49 UTC
(In reply to V Stuart Foote from comment #16)
> (In reply to Kerry Hjertaas from comment #15)
> > This issue seems to be back for me now, in LibreOffice 6.1.0.3 (x64).
> > 
> > About LibreOffice screens shows this:
> > 
> > Version: 6.1.0.3 (x64)
> > Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
> > CPU threads: 8; OS: Windows 6.1; UI render: default; 
> > Locale: en-US (en_US); Calc: group threaded
> > 
> > 
> > This was working prior to my LibreOffice install updating itself to the
> > latest version on September 4th.  Liberation Sans, Liberation Sans Narrow
> > and Liberation Serif all look like Liberation Mono.
> 
> New issue please. And, what is needed is a verbose installation log.
> 
> i.e. from a Command prompt "Run as Administrator" command line:
> 
> msiexec.exe /i LibreOffice_6.1.0.3_Win_x64.msi /L*v lo610installLog.txt
> 
> Then, if issue actually is repeated, zip the logfile and attach to a new BZ
> issue.

Kerry was not in CC, so adding to be sure.
Kerry: you need to open a new report.