Bug Hunting Session
Bug 65634 - Trackpad scrolling not possible on Sidebar Properties Pane
Summary: Trackpad scrolling not possible on Sidebar Properties Pane
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.4.0 target:4.3.0.2
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2013-06-11 07:23 UTC by Emir Sarı (away)
Modified: 2016-10-24 13:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2013-06-11 07:23:48 UTC
Steps to reproduce:

1. Enable Sidebar
2. Undock the Sidebar
3. Shrink the sidebar, so that scrolling bars appear
4. Make sure Properties Pane is active
5. Try to do two-finger scrolling

Expected behaviour:

Scrolling window contents

Actual behaviour:

It does not scroll. :(
Comment 1 Jorendc 2013-06-20 14:52:27 UTC
I can confirm this using Mac OSX 10.8.3 with LibreOffice Versie: 4.1.0.0.beta2 
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6; Dutch UI;

Kind regards,
Joren
Comment 2 Emir Sarı (away) 2013-07-26 22:56:36 UTC
I can also reproduce this bug when the sidebar is docked under 4.1.0.4.
Comment 3 Emir Sarı (away) 2013-08-22 06:24:24 UTC
This issue is actually somewhat very annoying, especially in calc, where sidebar is very detailed.
Comment 4 Emir Sarı (away) 2013-12-19 06:58:56 UTC
Raising importance to "Major", since this is an important UX issue and still has not been fixed before RC2.
Comment 5 Mihkel Tõnnov 2014-01-24 12:25:46 UTC
This affects me under Linux, too -- setting platform to All-All.
Comment 6 Paijo 2014-05-05 08:54:00 UTC
Tested on LO 4.2.3.3 under Ubuntu, and 4.2.2.1 running on WindowsXP.

I confirm I can reproduce the bug in both platform, sidebar docked as well as undocked.

Even if clicking the scrollbar to make the scroll-thumb jumps, didn't work as expected.
Comment 7 V Stuart Foote 2014-06-18 14:58:23 UTC
Looking at this on Windows 7 sp1, 64-bit en-US with
Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Seems like the Scroll bars are not even implemented in UI. So, when undocked the frame/dialog can be resized, but does not render with scroll bars.
Comment 8 Commit Notification 2014-06-27 13:43:54 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=641154c259334874bbbcb735f0064f3241f293ad

Resolves: fdo#65634 improve wheel-scrolling sidebar panels



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-06-27 14:55:01 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df630b8f8c2c92ec2cd1e4be6a3f54a4e4960e92

Related: fdo#65634 make sidebar react to resizes when floating



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-06-27 14:58:47 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7aeef829fdc25a60530c776c8f4958b7415384ce&h=libreoffice-4-3

Related: fdo#65634 make sidebar react to resizes when floating


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2014-06-27 15:08:33 UTC
I believe there are two problems here.

a) When in floating mode the sidebar doesn't adapt to the size of the floating window
b) That scrolling only works if the vertical scrollbar is explicitly used (or wheel/trackpad scrolling while over it)

a is easy, b is tricky because if e.g. a spinbutton is brought under the pointer position when wheeling then the spin button will start incrementing. I've resolved this by tweaking wheeling to reuse the *previous* widget as the target if the position of the pointer is exactly the same as it was on the previous wheel and there time gap is < 1/2 a second. i.e you can scroll up and down with the wheel and spinbuttons etc are ignored unless you move or wait before doing it again.