Download it now!
Bug 65635 - Huge Dialog Boxes
Summary: Huge Dialog Boxes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.0.2
Keywords: regression
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2013-06-11 07:52 UTC by Emir Sarı
Modified: 2013-07-27 14:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1 (169.18 KB, image/png)
2013-06-11 07:55 UTC, Emir Sarı
Details
Screenshot 2 (184.57 KB, image/png)
2013-06-11 07:56 UTC, Emir Sarı
Details
Screenshot 3 (170.37 KB, image/png)
2013-06-11 07:57 UTC, Emir Sarı
Details
Screenshot 4 (162.87 KB, image/png)
2013-06-11 07:57 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2013-06-11 07:52:02 UTC
Starting with 4.1. branch, dialog boxes in OS X got huge, I mean real huge. 

Will add relevant screenshots now.
Comment 1 Emir Sarı 2013-06-11 07:55:31 UTC
Created attachment 80656 [details]
Screenshot 1
Comment 2 Emir Sarı 2013-06-11 07:56:19 UTC
Created attachment 80657 [details]
Screenshot 2
Comment 3 Emir Sarı 2013-06-11 07:57:15 UTC
Created attachment 80658 [details]
Screenshot 3
Comment 4 Emir Sarı 2013-06-11 07:57:50 UTC
Created attachment 80660 [details]
Screenshot 4
Comment 5 Caolán McNamara 2013-06-21 12:19:37 UTC
So... a dialog will be as large as its largest page.

In the character dialog there are now two extra lines for the "the same font will be used in..." messages for the CJK and CTL categories as well as the Western one. That's the tallest page in that dialog when CTL and CJK is enabled. I think I'm happy enough with that outcome. Unless its the width that's bugging you ?

In the paragraph dialog indents and spacing is (in 4-1 the tallest) so the height is in or around the same as it always was. I can live with that height.

In the properties dialog the general page is the tallest, and there's *way* too much space between the lines. Can't live with that. Some debugging shows that the selectable labels are request extra height for a gap to their borders, but they don't have borders. I'll fix that.
Comment 6 Commit Notification 2013-06-21 12:30:14 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a5c151b62a7abc3fc4abaadb0b50c3047eb5f26

Resolves: fdo#65635 don't include border gap in height for borderless edits



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Emir Sarı 2013-06-21 12:41:20 UTC
Well, it's not about being fine with size or not, there are considerable size differences on dialog boxes with 4.0 and 4.1 branch, and considering each pixel is valuable on laptop screens, it is a significant UX issue, and most people will be bothered by that. 

I have a Mac with 1280x800 screen and new dialog boxes nearly take all the space on my screen. And I thought it is worth to report, after seeing most dialog boxes became smaller and neater after the new widget conversion thing, and this issue surprised me, because it is something with a totally different direction than expected. 

But anyway, thanks for the fix, after verifying that if problem still continues I'll attach screenshots with comparisons with the 4.0 branch.
Comment 8 Caolán McNamara 2013-06-21 12:45:57 UTC
I've requested a review for the 4-1 branch for the above fix. If you feel certain dialogs are still excessively large then feel free to use a new bug for that, but lets keep this one for the property dialog alone as it won't be a single fix fits all.

Some comparative screen shots in any follow up bugs would be helpful, the thing to do in the new dialogs is to find the pages which "fill" the dialog as those are the ones that enforce the overall dialog size
Comment 9 Commit Notification 2013-06-21 13:35:28 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=874dad99efd531abcad486a6b1abc21c13194bb0&h=libreoffice-4-1

Resolves: fdo#65635 don't include border gap in height for borderless edits


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.