Bug Hunting Session
Bug 65644 - EDITING: memo [LONGVARCHAR] fields not saved
Summary: EDITING: memo [LONGVARCHAR] fields not saved
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-11 09:14 UTC by carlohkarlo
Modified: 2015-03-14 22:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carlohkarlo 2013-06-11 09:14:34 UTC
Problem description: 

Steps to reproduce:
1. create a MEMO [LONVARCHAR] field (eg: "object_description")
2. create a form with a control field for "object_description" (either as multiline or formatted text)
3. input some text into the record
4. save everything and close base
5. open base and load the database again

Current behavior:
- no text is now saved into the record

Expected behavior:
- text will be safely saved and kept

NOTE: I thought it may be related to the multiline input in the control box; but actually changing the field to TEXT [VARCHAR], even with a very long fixed number of characters, like 10000, seems to be working fine. The problem must be related with the MEMO [LONVARCHAR] kind of field.
              
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 Robert Großkopf 2013-06-11 14:56:05 UTC
Can't confirm for OpenSUSE 64bit rpm, LO 4.0.4.1
Comment 2 Terrence Enger 2014-07-21 19:30:33 UTC
(In reply to comment #0)

What backend database are you using, and how do you connect to it?
Especially if you are using an embedded database (HSQLDB or Firebird),
an attachment deomonstrating the problem would be most helpful.

LibreOffice 4.0.3 is quite old.  Can you try a newer version and see
if the problem still exists?  For that matter, has this ever workied
in LibreOffice?

When you reply, please set the bug status back to UNCONFIRMED.

Thanks,
Terry.
Comment 3 Alex Thurgood 2015-01-03 17:39:05 UTC
Adding self to CC if not already on
Comment 4 Julien Nabet 2015-03-14 22:00:49 UTC
No feedback since more than 6 months, let's put this one to WFM

Carlo: don't hesitate to reopen this tracker if you can reproduce this with recent LO version (4.4.1 or 4.3.6). In this case, please tell which DB backend you use.