Download it now!
Bug 65717 - FILEOPEN: DOCX import - picture with 'Square' wrapping style is rendered incorrectly
Summary: FILEOPEN: DOCX import - picture with 'Square' wrapping style is rendered inco...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-13 15:36 UTC by Adam CloudOn
Modified: 2013-10-28 08:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing text and a picture with 'Square' wrapping style (56.79 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-13 15:36 UTC, Adam CloudOn
Details
can't reproduce comparison screenshot (215.09 KB, image/png)
2013-06-20 23:24 UTC, Jorendc
Details
Bug 65717 Comparison Screenshot (147.83 KB, image/png)
2013-06-23 08:36 UTC, Adam CloudOn
Details
Comparison between Word 2013 [Win8] to LO master [Linux] (153.91 KB, image/png)
2013-06-24 11:58 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-06-13 15:36:12 UTC
Created attachment 80783 [details]
DOCX containing text and a picture with 'Square' wrapping style

Problem description: 
Attached is a DOCX that contains an image that it's wrapping style is set to 'Square'.
The text wrapped around the image is spread differently in LO then in Word.

Steps to reproduce:
1. Open the attached DOCX in LO.
2. The text around the image is spread differently than in Word.

Current behavior:
Text around the image does not look the same as in Word.

Expected behavior:
Text around the image should look the same as in Word
              
Operating System: Windows 8
Version: 4.0.3.3 release
Comment 1 Jorendc 2013-06-20 23:24:38 UTC
Created attachment 81137 [details]
can't reproduce comparison screenshot

@Adam: you mind uploading a comparison screenshot?

I think I can't reproduce this one using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 and Word for Mac 2011.
Comment 2 Adam CloudOn 2013-06-23 08:36:24 UTC
Created attachment 81259 [details]
Bug 65717 Comparison Screenshot

I've added a screenshot comparing Word 2013 and LO (master build, almost latest).
Comment 3 retired 2013-06-24 10:02:10 UTC
I also cannot reproduce this problem on OS X 10.8.4 and LO 4.1.0.1.

I see just the same as Jorendc (see screenshot he posted).

Thus setting to WORKSFORME.

If Word 2013 on windows decides to display this doc differently than MS Office 2011 for mac, that isn't really a LO bug.
Comment 4 Adam CloudOn 2013-06-24 11:58:34 UTC
Created attachment 81332 [details]
Comparison between Word 2013 [Win8] to LO master [Linux]

In the previous screenshot that I've uploaded - I confused the location of 'Word 2013' and 'LO' in the screenshot.
I've uploaded the screenshot again with the correct locations.
I've tested Word 2011 on Mac OS X, and also Word 2013 on Windows 8.
So I got the same results as @Jorendc and @James.
The problem is with how *LIBREOFFICE* renders the text.
Comment 5 Adam CloudOn 2013-06-24 12:00:38 UTC
(In reply to comment #1)
> Created attachment 81137 [details]
> can't reproduce comparison screenshot
> 
> @Adam: you mind uploading a comparison screenshot?
> 
> I think I can't reproduce this one using Mac OSX 10.8.3 with LibreOffice
> Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 and Word
> for Mac 2011.

I am checking against latest master branch build:

Version: 4.2.0.0.alpha0+
Build ID: 865b5caf6e2256e06f46a39a86d67f03408718a9
Comment 6 Jacques Guilleron 2013-06-24 12:54:24 UTC
Hello Adam,

I have the same results than Joren on windows 7 Home Premium. To get a similarly displaying, I have to set Calibri above 22 points. I wonder if we are using the same font. On Windows 7, Calibri font version is 5.72. On Windows 8, is it the same number version?

regards,

Jacques Guilleron
Comment 7 Adam CloudOn 2013-06-24 12:59:38 UTC
(In reply to comment #6)
> I have the same results than Joren on windows 7 Home Premium. To get a
> similarly displaying, I have to set Calibri above 22 points. I wonder if we
> are using the same font. On Windows 7, Calibri font version is 5.72. On
> Windows 8, is it the same number version?

@Jorendc and @Jacques Guilleron  : 
On Windows 8 - I have the same result as you guys (LO shows it like Word).
The problem is when I run the latest build on **LINUX** Ubuntu 12.04 LibreOffice.

That's when it looks different.

So maybe it is something to do with Linux's fonts ?
Comment 8 Jacques Guilleron 2013-06-24 16:48:28 UTC
May be!... I explore what may happen? Can you provide some details on Calibri Fonts?

Thank you!

Jacques
Comment 9 Adam CloudOn 2013-06-25 07:32:57 UTC
(In reply to comment #8)
> May be!... I explore what may happen? Can you provide some details on
> Calibri Fonts?

@Jacques - I am not sure what you mean ... I am not a fonts guy... :\
Comment 10 Jacques Guilleron 2013-06-26 07:49:01 UTC
Hi Adam,

Don't worry. Someone else uusing Ubuntu 12.04 can he verify this behaviour?

Jacques Guilleron
Comment 11 ign_christian 2013-06-26 09:47:43 UTC
I can confirm same result as Jorendc running LO 3.6.6.2 (Ubuntu 12.04 32bit). 
But...of course I have had Calibri font installed on my Ubuntu ;)
(taken from my font folder on Win7 - hope that not violate copyright issue :))

Simply click on drop-down 'Font name' list, if the font not listed there means system nor LO don't have the font.

Anyway..(I think) Ubuntu renders font differently with Winows. I always saw my presentation file displayed with slightly different spacing while opened in Ubuntu compare to Win7. It's wider on Ubuntu, similar to Adam's screenshot - but I think not that wide (perhaps that's because Calibri font not installed).

So I think that's not a bug, except developer would enrich fonts collection in LO :-)
Comment 12 Adam CloudOn 2013-06-26 10:05:11 UTC
(In reply to comment #11)

> Simply click on drop-down 'Font name' list, if the font not listed there
> means system nor LO don't have the font.

I just checked - and indeed - I do not have Calibri installed.
So is this a bug in LO ?
maybe if it doesn't find Calibri it should use a different font than what is being used today? maybe something more similar to Calibri that it *does* have in its installation ?
Comment 13 ign_christian 2013-06-27 02:49:06 UTC
> I just checked - and indeed - I do not have Calibri installed.
> So is this a bug in LO ?
http://ask.libreoffice.org/en/question/15041/calibri-and-cambria-fonts-in-libreoffice/
http://ubuntuforums.org/showthread.php?t=1664796&page=3
So it's copyrighted by Microsoft :(

> maybe if it doesn't find Calibri it should use a different font than what is
> being used today? maybe something more similar to Calibri that it *does*
> have in its installation ?
I think that's what LO did, LO will use closest/similar font (which you had on your system) with Calibri. So the result is as displayed on your screenshot.
Comment 14 ign_christian 2013-06-28 02:21:29 UTC
I had removed Calibri font (due to copyright issue) from my Ubuntu & confirm same result as Adam.

Nothing wrong with LO, so it's not a bug.
Comment 15 retired 2013-10-28 08:20:38 UTC
NOTABUG as of comment 12 and 14.