Bug 65762 - REPORTBUILDER: Crash of LO when trying to open or create a report
Summary: REPORTBUILDER: Crash of LO when trying to open or create a report
Status: RESOLVED DUPLICATE of bug 64279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 65951 (view as bug list)
Depends on:
Blocks: Database-Reports-Builder-MAB
  Show dependency treegraph
 
Reported: 2013-06-14 16:59 UTC by Robert Großkopf
Modified: 2013-06-21 05:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the file, try to start the report ... (18.01 KB, application/vnd.sun.xml.base)
2013-06-17 15:59 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-06-14 16:59:58 UTC
Open a database with LO 4.0.4.2. 
Try to crate a report. 
LO crashes immediately.

Open a database with a created report.
Try to run the report.
LO crashes immediately.

ReportBilder couldn't be used with LO 4.0.4.2, Linux rpm, 64bit, OpenSuSE 12.3
Comment 1 Joel Madero 2013-06-17 15:34:54 UTC
Can you attach a document with a created report? I don't have one easily available (or available at all) but I'll test it if you attach a document

Marking as NEEDINFO - attach the database (as simple as possible) and mark as UNCONFIRMED and I will confirm today
Comment 2 Joel Madero 2013-06-17 15:50:24 UTC
So more info - I just created a new database (no data) and clicked on created a report and it didn't crash.
Comment 3 Robert Großkopf 2013-06-17 15:59:52 UTC
Created attachment 80959 [details]
Open the file, try to start the report ...

Only one table and a report without any tricks. Try to start it with LO 4.0.4.2 rc. LO crashes.
You don't need the report. You could try to edit a new report. LO crashes.
Comment 4 Robert Großkopf 2013-06-17 16:03:34 UTC
(In reply to comment #2)
> So more info - I just created a new database (no data) and clicked on
> created a report and it didn't crash.

OK, have tested: I can open the window for creating the report. But when I close the window LO crashes.
I can't change an edited report. LO crashes.
Comment 5 Joel Madero 2013-06-17 16:03:56 UTC
No crash for me - please try with a clean profile: 

https://wiki.documentfoundation.org/UserProfile
Comment 6 Robert Großkopf 2013-06-17 19:06:45 UTC
(In reply to comment #5)
> No crash for me - please try with a clean profile: 
> 
> https://wiki.documentfoundation.org/UserProfile

This is the first thing I do, when I have problems with LO. It isn't a problem in the UserProfile.

So I have tried it with another System on another PC: OpenSUSE 12.3 32bit rpm. Downloaded the 32-bit-versin of LO 4.0.4.2, put it on a laptop, which works with this system, started the attachment, started the report - LO crashed immediately. 

Which system do you use? Could it be a special problem of the rpm-packages?
Comment 7 Joel Madero 2013-06-17 19:15:27 UTC
Might be - I'm running Bodhi Linux (build based on Ubuntu 12.04).

I'll poke around and see if any other QA people are running rpm based machine. Thanks for additional input
Comment 8 Planas 2013-06-17 19:47:11 UTC
With openSUSE 12.3 and LO 4.0.3 the same problem occurs with Report Builder and Base crashing when creating a report. The database was from mysql which was imported correctly.
Comment 9 m.a.riosv 2013-06-17 20:14:03 UTC
Maybe an issue with Java?
Is it selected in Menu/Tools/Options/LibreOffice/Advanced?
Comment 10 Robert Großkopf 2013-06-18 05:28:55 UTC
(In reply to comment #8)
> With openSUSE 12.3 and LO 4.0.3 the same problem occurs with Report Builder
> and Base crashing when creating a report. The database was from mysql which
> was imported correctly.

That must be another problem. I have also installed openSUSE 12.3. LO 4.0.3.3 is running without any problem with the report-builder. The problem first occurs with LO 4.0.4.2 rc (could be also 4.0.4.1 rc - haven't tested it there. 
The problem doesn't exist, for example, in 4.1.0.0 beta 2.

It isn't a special problem with Java. I have installed two versions of Java: 1.6.0_22 (I am mostly working with LO 3.3.4) and openjdk 1.7.0_21. Both versions work with LO 4.0.3.3 and the report-builder. Both versions didn't work with LO 4.0.4.2 rc and the report-builder.
Comment 11 Thomas Hackert 2013-06-20 11:39:22 UTC
Hello Robert, *,
I can confirm it insofar, that LO Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) under Debian Testing AMD64 crashes immediately, when I rightclick on an own report in my test db and choose "Edit" there ... :(

If I want to open the report in your attached document, I get the message
<quote>
SQL-Status: S1000
Fehler-Code: -40

General error: org.hsqldb.lib.FileSystemRuntimeException: java.io.IOException: /home/baseline/core/package/source/xstor/xstorage.cxx:3163:
</quote>
... :(

Not sure, why ...
HTH
Thomas.
Comment 12 Robert Großkopf 2013-06-20 20:36:51 UTC
*** Bug 65951 has been marked as a duplicate of this bug. ***
Comment 13 Lionel Elie Mamane 2013-06-21 04:48:27 UTC
This smells like it is a duplicate of bug 64279. Reopen if it is not fixed in daily builds of libreoffice-4-0 or libreoffice-4-1.

This is further hinted by comment 10 saying "this problem does not exist in 4.1.0.beta2", which is (along with 4.0.5 and master) where bug 64279 is fixed.

*** This bug has been marked as a duplicate of bug 64279 ***