Download it now!
Bug 65771 - formula in the text
Summary: formula in the text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-14 22:38 UTC by Egon
Modified: 2013-08-06 04:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the original doc fragment after cut and undo (11.33 KB, image/png)
2013-06-18 08:25 UTC, Yury
Details
script changing all formulas properties fails on formula replaced-with-object (30.38 KB, image/png)
2013-06-18 17:57 UTC, Yury
Details
the doc with the corrupted object (9.85 KB, application/vnd.oasis.opendocument.text)
2013-06-22 15:03 UTC, Yury
Details
sample saved 'as is' (8.92 KB, application/vnd.oasis.opendocument.text)
2013-06-27 20:16 UTC, Yury
Details
sample with formula source corrected then saved (8.46 KB, application/vnd.oasis.opendocument.text)
2013-06-27 20:17 UTC, Yury
Details
attachment-587-0.html (3.66 KB, text/html)
2013-06-28 12:44 UTC, Egon
Details
attachment-587-1.dat (1 bytes, multipart/alternative)
2013-06-28 12:44 UTC, Egon
Details
5xx8-Q-Bugggggzilla.odt (156.89 KB, application/vnd.oasis.opendocument.text)
2013-06-28 12:44 UTC, Egon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egon 2013-06-14 22:38:04 UTC
There has been created a form. In that form there are a couple of math formulas, very simple. IN Open Office the form worked fine. Saved a lot of typing, especially errors.
Opening this file in Libre office kills most of the formulas, they appear if klicked on the field, but they don't work at all. Not even wrong, they simply don't do anything. I don't know how to program these formulas, so that they work again. If need be, I could send one page.
Comment 1 Yury 2013-06-15 05:40:27 UTC
I have seen similar behaviour in 3.* series on linux, but after copying/pasting formula. 

In such cases, formulas were being pasted as uneditable objects ('OLE objects' or something). I cannot reproduce it, at least not in 3.6.*, but I believe the way of selecting formula had something to do with the bug: selecting a piece of text with formula in it or clicking on a formula's frame.

I understand this is thin evidence, of course, but the unwanted 'auto-conversion' to uneditable objects -- very like the one Egon'd reported -- definitely had been happening here.
Comment 2 Yury 2013-06-18 08:24:20 UTC
Just a minute ago experienced this (effective) formula corruption in process of clipboarding (text with) formulas on 3.6.5.2/Linux/AMD64. Can't yet reproduce, though, have only the proofpic of outcome.

What led to the outcome shown was:

1) Had text set in 'Charter', all font faces in Formula editor defaulted to 'Charter'.

2) Had one formula created (Insert->Object->Formula) from text selection containing scripted glyphs B and V either from 'Neo Euler' or 'Asana Math' (or from both, can't precisely remember). Glyphs were inserted from the 'Insert special character' dialog.

3) As 'Charter' doesn't have these glyphs, the rendered picture showed squares instead of glyphs. So went to Editor and replaced those (which were shown correctly in the 'text view' of formula, anyway) with ASCII counterparts.

All seemed to be well until I tried to cut and paste this text fragment. Having CUT (Ctrl+X) made (but NO save!), switched to another Writer window, pasted (Ctrl+V or Shift+Ins, can't remember precisely).

Noticed one formula changed (this same one)!! All other formulas (ten or so) were okay. So went back to the original window, made UNDO (Ctrl+Z), BUT, it happened, the formula in question was replaced by un-openable 'Object 28' here as well, with no further undo possibility (grayed)!!

The proofpic shows the original document fragment after the cut and undo.
Comment 3 Yury 2013-06-18 08:25:35 UTC
Created attachment 80987 [details]
the original doc fragment after cut and undo
Comment 4 Yury 2013-06-18 17:57:04 UTC
Created attachment 81029 [details]
script changing all formulas properties fails on formula replaced-with-object

This is what happens in replaced-with-object formula when I try to run the script changing font/etc. settings in all formulas (Python).
Comment 5 Joel Madero 2013-06-20 17:55:53 UTC
Indeed - please provide a sample document here so we can take a look at it.

Marking as NEEDINFO - apologies for the long delay in getting to this one in order to triage. 

Once you attach a sample (the simpler the better) mark as UNCONFIRMED and we will try to reproduce.


Thanks!
Comment 6 Yury 2013-06-22 15:03:46 UTC
Created attachment 81218 [details]
the doc with the corrupted object

This is the doc with the corrupted formula object only. Unfortunately, I didn't catch the state of the doc before (unwittingly saved over after corruption but before detection).
Comment 7 Yury 2013-06-27 20:16:46 UTC
Created attachment 81582 [details]
sample saved 'as is'

Here's a 100% reproducible recipe for formula corruption (and it's corruption on creation of formula per se).

Make doc, put one "over 64K code" glyph into it, make formula from it (I did this with 'Neo Euler-like bold B' U+10FE88 from Asana Math in mine sample). In formula preview the glyph comes out as a 'have no such glyph' square (the default font in formulas here is Charter).

Now you may save it 'as is', or you may correct the formula source (put something 100% acceptabel, like ASCII letter), then save. Eiter way you get a document with corrupted formula (showing as 'Object #something').

I'm attaching two sample docs, one saved as is (this one), another corrected (changed source to 'latin B'), then saved.
Comment 8 Yury 2013-06-27 20:17:19 UTC
Created attachment 81583 [details]
sample with formula source corrected then saved
Comment 9 Egon 2013-06-28 12:44:33 UTC
Created attachment 81636 [details]
attachment-587-0.html

Hi,
Sorry, I have been outside the internet for the past week. In the 
attached file you find a column with Prices, which are all 0,00. If you 
point with the mouse without click, you see, that there is a formula in 
the field. You also see the red number, which is also a formula field, 
that doesn't work properly anymore. The address is not valid and the 
rest is anonymized, so fear yee not. there is not much you can do wrong. 
Please get the bug fixed.
Thank you.



On 20/06/2013 19:55, bugzilla-daemon@freedesktop.org wrote:
> Joel Madero <mailto:jmadero.dev@gmail.com> changed bug 65771 
> <https://bugs.freedesktop.org/show_bug.cgi?id=65771>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		jmadero.dev@gmail.com
> See Also 		https://bugs.freedesktop.org/show_bug.cgi?id=65765
> Ever confirmed 		1
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=65771#c5> 
> on bug 65771 <https://bugs.freedesktop.org/show_bug.cgi?id=65771> from 
> Joel Madero <mailto:jmadero.dev@gmail.com> *
> Indeed - please provide a sample document here so we can take a look at it.
>
> Marking as NEEDINFO - apologies for the long delay in getting to this one in
> order to triage.
>
> Once you attach a sample (the simpler the better) mark as UNCONFIRMED and we
> will try to reproduce.
>
>
> Thanks!
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 10 Egon 2013-06-28 12:44:33 UTC
Created attachment 81637 [details]
attachment-587-1.dat
Comment 11 Egon 2013-06-28 12:44:33 UTC
Created attachment 81638 [details]
5xx8-Q-Bugggggzilla.odt
Comment 12 Yury 2013-06-28 16:41:31 UTC
Egon and I are talking about differently defined formula. Egon means calculated formulas, I mean formula/equation editor.
I've created # 66333 for my issue.
Comment 13 Egon 2013-08-05 19:59:58 UTC
HI
I updated my system and am working now with Libre Office 4. something. 
Everything works fine. Thank you
Gottfried

On 27/06/2013 22:17, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=65771#c8> 
> on bug 65771 <https://bugs.freedesktop.org/show_bug.cgi?id=65771> from 
> Yury <mailto:yury.tarasievich@gmail.com> *
> Createdattachment 81583  <attachment.cgi?id=81583>  [details]  <attachment.cgi?id=81583&action=edit>
> sample with formula source corrected then saved
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 14 ign_christian 2013-08-06 04:28:11 UTC
WORKSFORME per comment 13. Please REOPENED if problem persists in upcoming release