Bug Hunting Session
Bug 65806 - TABLE: selected lines of table does not match
Summary: TABLE: selected lines of table does not match
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-15 22:55 UTC by LARJ
Modified: 2014-08-05 15:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LARJ 2013-06-15 22:55:06 UTC
Versão 4.0.2.2 (ID da versão: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
Ubuntu 12.04 AMD-64 Kernel 3.8

Problem description: 

Steps to reproduce:
1. I select a table line;
2. I press shift key;
3. I press up or down arrow keys or the last line of the block I want to select.

Current behavior: selected block does not correspond to expected between first and last lines selected.

Expected behavior: selected cells block showd correspond to the area between the first and last lines selected

              
Operating System: Ubuntu
Version: 4.2.0.0.alpha0+ Master
Comment 1 Joel Madero 2013-06-20 19:13:22 UTC
I am a bit unclear on what you expect.

What I did:

Open writer
Insert Table 4x4
Highlighted Row 1 (1x4)
Hold Ctrl, push down

Observed: Now row 1 and 2 (2x4) are selected


This is what I expect, are you expecting something else?



Marking as NEEDINFO as I'm not sure what you're expecting to see. Also, did this work differently in a previous version? Version field should be the oldest version you see the bug, not the newest which was tested -> so unless this is a change or regression, the bug should not be marked at 4.2 master

Please provide additional input and then mark bug as UNCONFIRMED and we'll investigate again.


Thanks!
Comment 2 Jean-Baptiste Faure 2013-11-27 20:53:30 UTC
I think that the expected behavior is what follows:
1/ move the mouse pointer on the left of the table in front of a row until it becomes an arrow pointing to the right
2/ left click => the row is selected
3/ move the mouse pointer several rows down
4/ move the pointer until it becomes an arrow pointing to the right
5/ press shift and left click

expected behavior: the block of rows is selected
current behavior: if the mouse pointer is a little too far from the table border it does not work.

So it works as expected but in a way slightly disconcerting. I am not if we can consider that as a bug. So set status back to UNCONFIRMED

Tested with the same behavior on version 4.0.6, 4.1.5.0.0+ and 4.2.0.0.beta1+
So set version to 4.0.6

Best regards. JBF
Comment 3 sophie 2014-08-05 15:00:44 UTC
Hi, I agree that the cursor of selection has to be really near the border for it to work, but that's not a bug as it works as expected, the selection is made :) Closing - Sophie