Bug 65811 - Implement Priority System for Status Bar Elements, so It's Better Resizable
Summary: Implement Priority System for Status Bar Elements, so It's Better Resizable
Status: RESOLVED DUPLICATE of bug 42894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 09:36 UTC by Stefan Knorr (astron)
Modified: 2016-04-28 04:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2013-06-16 09:36:53 UTC
Currently, when resizing the window too small (e.g. when editing two documents side by side), one loses the arguably most important feature of the status bar, zoom – because it is located at the far right and so just pushed out.

It would be better, if we instead lost things that people tend to use less often. Therefore, we need a priority system that e.g. assigns every status bar element a number, throwing the elements with the highest number out first.

Short example for Writer, informed by my own usage only:
#1  Zoom percentage
#2  Zoom controls
#3  Page number/count
#4  Language selector
#5  Single page/multiple pages/book view
#6  Page style
#7  Insert/Overwrite mode indicator
#8  Word count
#9  Signature indicator
#10 Selection status indicator
#11 Saving status indicator

When that is done, a further idea would be to implement shorter versions of the most space-grabbing status bar elements, like the word count or the Overwite mode indicator.
Comment 1 Adolfo Jayme 2016-04-28 04:25:03 UTC

*** This bug has been marked as a duplicate of bug 42894 ***