Bug Hunting Session
Bug 65813 - Industrial icons in Tango toolbar
Summary: Industrial icons in Tango toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Theme-Tango
  Show dependency treegraph
 
Reported: 2013-06-16 09:50 UTC by Stefan Knorr (astron)
Modified: 2017-07-31 23:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Industrial icons in the toolbar (Open, Print directly, Spellcheck) (13.58 KB, image/png)
2013-06-16 09:50 UTC, Stefan Knorr (astron)
Details
Old icons bug (6.73 KB, image/png)
2013-07-09 09:42 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2013-06-16 09:50:09 UTC
Created attachment 80895 [details]
Industrial icons in the toolbar (Open, Print directly, Spellcheck)

Some Industrial icons seem to have snuck into the toolbar in the changes between 4.1 and 4.2 master... clearly a regression.
Comment 1 retired 2013-06-24 10:10:56 UTC
Can confirm this. Setting to NEW.
Comment 2 Stefan Knorr (astron) 2013-06-27 15:08:33 UTC
Hm, I've looked at this and this is (immediately at least) caused by the deletion of some duplicate icons
  http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b1f4587400c7f76b96f4932d09a657c6c618d6f

However, I guess it is really due to the script solenv/bin/packimages.pl not working, as during build I get these messages:
  [build PRL] CustomTarget/postprocess/images/images_hicontrast.zip
  no links in /home/user/lo-apply/code/core/icon-themes/galaxy/links.txt
  no links in /home/user/lo-apply/code/core/workdir/unxlngx6.pro
  /CustomTarget/postprocess/images/links.txt
  no links in /home/user/lo-apply/code/core/icon-themes/galaxy/links.txt
  no links in /home/user/lo-apply/code/core/icon-themes/crystal/links.txt
  no links in /home/user/lo-apply/code/core/icon-themes/industrial/links.txt

However, there definitely is text in these files – so either the format is wrong or the script does not do what it should.
Comment 3 ape 2013-07-09 09:42:13 UTC
Created attachment 82221 [details]
Old icons bug

What to do with this (an attachment)?
 Astron, I was discussing this issue with you and offer options for icons in the last year. But the problem remained unsolved.
Comment 4 ape 2013-07-09 13:58:04 UTC
(In reply to comment #3)
> Created attachment 82221 [details]
> Old icons bug
> 
> What to do with this (an attachment)?
>  Astron, I was discussing this issue with you and offer options for icons in
> the last year. But the problem remained unsolved.

Astron, the page address of discussion:
http://nabble.documentfoundation.org/New-icons-in-Tango-td3905093.html#a3998356
--
ape
Comment 5 Stefan Knorr (astron) 2014-02-27 08:11:51 UTC
All fixed in 4.2.0 final and recent master. Resolving fixed.