Bug Hunting Session
Bug 65833 - FILESAVE: DOCX exporting screenshot inside canvas loses canvas and shows rectangles
Summary: FILESAVE: DOCX exporting screenshot inside canvas loses canvas and shows rect...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 16:13 UTC by Adam CloudOn
Modified: 2015-06-22 14:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing screenshot inside canvas (33.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-16 16:13 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-06-16 16:13:22 UTC
Created attachment 80915 [details]
DOCX containing screenshot inside canvas

Problem description: 
Opened the attached DOCX in LO (the DOCX contains a screenshot inside a canvas). When saving as a NEW.DOCX and opening it in Word - the DOCX contains the screenshot, but not in a canvas. Also there are a lot of rectangles.

Steps to reproduce:
1. Open attached DOCX in LO.
2. Save as NEW.DOCX
3. Open NEW.DOCX in Word
4. Canvas is lost and there are rectangle.

Current behavior:
Canvas is lost and there are rectangle.

Expected behavior:
Screenshot should be inside canvas (with no rectangles)
              
Operating System: Ubuntu
Version: 4.2.0.0.alpha0+ Master
Comment 1 m.a.riosv 2013-06-16 23:58:46 UTC

*** This bug has been marked as a duplicate of bug 65832 ***
Comment 2 Adam CloudOn 2013-06-17 05:24:39 UTC
This should not be marked as duplicate, because the outcome of both bugs is dofferent.
One creates a corrupted file, while the other creates a 'wrong' file !
Comment 3 Adam CloudOn 2013-06-17 05:29:39 UTC
Sorry, I thought you marked it as a duplicate of 
https://bugs.freedesktop.org/show_bug.cgi?id=65836

However, this is still not a duplicate ofhttps://bugs.freedesktop.org/show_bug.cgi?id=65832
Because 65832 talks about import and from DOCX this talks about export to DOCX.
Comment 4 m.a.riosv 2013-06-17 19:52:48 UTC
Ok, but seems it is following the issue that appears when importing, as reported in https://bugs.freedesktop.org/show_bug.cgi?id=65832.

Have you try creating from scratch in LibreOffice?
Comment 5 Adam CloudOn 2013-06-18 07:26:42 UTC
(In reply to comment #4)
> Ok, but seems it is following the issue that appears when importing, as
> reported in https://bugs.freedesktop.org/show_bug.cgi?id=65832.
> 
> Have you try creating from scratch in LibreOffice?

I don't understand what this has to do with the 'import' bug.
It is 2 separate bugs.
Import bug causes it to render wrong (shows the screenshot twice).
Export bug (this bug) causes the DOCX to lose information (shows the screenshot, but it is not inside a canvas and it has a lot of rectangles around it).
Comment 6 Jorendc 2013-06-25 22:23:00 UTC
I can confirm this behavior using Mac OSX 10.8.3 with LibreOffice 4.1.0.1 RC and Word for Mac 2011. Thanks Adam :-)!

Kind regards,
Joren
Comment 7 Adam CloudOn 2013-07-10 12:56:22 UTC
Does not show multiple rectangles any more.
Now when Word recovers the file - it contains a simple empty rectangle.
Comment 8 Commit Notification 2014-01-13 16:49:28 UTC
Vinaya Mandke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4ff46485f0461de6a2804ae859dbbc81b6af105

fdo#65833 Fix to preserve VML Canvas Information



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Vinaya Mandke 2014-01-14 13:19:46 UTC
This patch fixes only the VML Issue.

Please verify this fix on MS Office 2007 as it renders the mc:Fallback VML part.
1. Open the attached file in MS Word 2007
2. Right Click on the Drawing-Canvas area
3. Menu must show "Format Drawing Canvas"
Comment 10 Joel Madero 2015-05-02 15:42:27 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 11 Buovjaga 2015-06-22 14:30:44 UTC
Original and roundtrip file now display as identical in MSO.
I get the Drawing canvas formatting options, when right clicking in the area.

Win 8.1 32-bit
MSO 2013

LibO Version: 5.1.0.0.alpha1+
Build ID: 2885e157674dbefa7d9b984a399fabd1238eeedd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-22_07:52:27
Locale: fi-FI (fi_FI)