Bug Hunting Session
Bug 65862 - FILESAVE: DOCX export quick table changes entire table layout and style
Summary: FILESAVE: DOCX export quick table changes entire table layout and style
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-17 13:08 UTC by Adam CloudOn
Modified: 2016-12-03 17:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing a 'Quick Table' (11.98 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-17 13:08 UTC, Adam CloudOn
Details
DOCX exported by LO with table that looks different (8.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-17 12:44 UTC, Adam CloudOn
Details
Screenshot comparison between original DOCX and exported DOCX (67.45 KB, image/png)
2013-11-17 14:05 UTC, Adam CloudOn
Details
visual mismatch (113.74 KB, image/png)
2014-02-05 06:06 UTC, Nikhil Walvekar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-06-17 13:08:32 UTC
Created attachment 80952 [details]
DOCX containing a 'Quick Table'

Problem description: 
DOCX was created in Word, and in the DOCX there was a 'Quick Table' inserted.
When opening the DOCX in LO and saving it as a NEW.DOCX - the table's layout is different (width of table is entire page, instead of just half a page).
In addition, the font colors and sizes are wrong.

Steps to reproduce:
1. Load attached DOCX in LO
2. Save as NEW.DOCX
3. Open NEW.DOCX in Word - table looks different than original

Current behavior:
Table is exported wrong to DOCX

Expected behavior:
Table should be exported correctly to DOCX
              
Operating System: Ubuntu
Version: 4.2.0.0.alpha0+ Master
Comment 1 Jorendc 2013-06-20 23:10:58 UTC
I can confirm this using Mac OSX 10.8.3 with Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155; and Word for Mac 2011.

Kind regards,
Joren
Comment 2 Adam CloudOn 2013-11-17 12:44:18 UTC
Created attachment 89352 [details]
DOCX exported by LO with table that looks different
Comment 3 Adam CloudOn 2013-11-17 14:05:24 UTC
Created attachment 89359 [details]
Screenshot comparison between original DOCX and exported DOCX
Comment 4 surbhi.tongia 2013-12-11 09:35:01 UTC
Verified on Build:libo-master~2013-12-11_02.11.28_LibreOfficeDev_4.3.0.0.alpha0_Win_x86 .
Now Quick table formatting is preserving.
Comment 5 Nikhil Walvekar 2014-02-05 06:04:05 UTC
on master branch @commit 5c39b6b997ddc85e6848efc230a427a124b97264
I am still able to see mismatch in rendering of table contents.

There is visible difference in spacing of the contents.
Comment 6 Nikhil Walvekar 2014-02-05 06:06:32 UTC
Created attachment 93428 [details]
visual mismatch

style reveal side bar showing differences in formatting.
Spacing values are differing, table styles are not applied in saved file.
Comment 7 Joel Madero 2014-11-06 00:45:31 UTC
Unclear if this is still a problem - looking for additional QA input. Moving to UNCONFIRMED. Thanks for your understanding and patience.
Comment 8 Buovjaga 2014-11-18 17:42:56 UTC
(In reply to Nikhil Walvekar from comment #6)
> Created attachment 93428 [details]
> visual mismatch
> 
> style reveal side bar showing differences in formatting.
> Spacing values are differing, table styles are not applied in saved file.

Looking at a .docx I saved with LibO 4.4 alpha from Nov 12 in MSO 2013. Preferred width of the cell is 1.27 cm (incorrect) like in the screenshot. Cell margins left & right are 0,19 cm (incorrect). Win 8.1.
Comment 9 QA Administrators 2015-12-20 16:20:39 UTC Comment hidden (obsolete)
Comment 10 Telesto 2016-12-03 17:13:57 UTC
Works for me. Tested with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL