Download it now!
Bug 65952 - Enter custom autocorrect entries without opening the replacement table
Summary: Enter custom autocorrect entries without opening the replacement table
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-20 04:36 UTC by tommy27
Modified: 2015-09-25 12:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
autocorrect righ-clik menu new GUI proposal (7.11 KB, image/png)
2013-06-20 04:36 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2013-06-20 04:36:46 UTC
Created attachment 81089 [details]
autocorrect righ-clik menu new GUI proposal

this is a clone of previous issue report I file in OOo bug-tracker in 2009 and that was never considered by OOo devs ( https://issues.apache.org/ooo/show_bug.cgi?id=101714 )

DESCRIPTION
when you type a wrong word and right click on it and go trough the autocorrect 
menu, LibO suggests you some alternative typing, if you find the desired one you click on it and you set an association that is recorded. Next time you type the mistake it will be automatically retyped.

unfortunately sometimes you don't find the desired typing among LibO's 
suggestion. In that case you may manually set the autocorrect association entering the autocorrect replacement table from the Tools menu.

my proposal is to add some kind of a form field in the right click autocorrect 
menu, just below the typing suggestions. The user should be able to manually 
type in that field the desired typing and set the error/autocorrect 
association. (if you don't understand what i mean see the attached screenshot 
example i made with some graphic editing software)

in this way you could enter a custom autocorrect entry without opening the 
whole autocorrect replacement table. This would be a time saver.
Comment 1 Igor Gnatenko 2013-06-21 11:28:16 UTC
Good idea, but I think not need.
Very few people are interested.
Comment 2 tommy27 2013-06-22 04:43:28 UTC
@Igor Gnatenko
I'm reverting the version number to 3.3 since this issue affects every LibO release and not only 4.1.0.1 as you modified (you should always select the firs LibO release where the issue is present)

I also REOPEN the bug report since RESOLVED WORKSFORME is a completely wrong label. this is an enhancement request, the fact you don't need it doesn't allow you to say it's RESOLVED.

you should better read bug triaging procedures.
Comment 3 Joel Madero 2013-06-24 14:23:39 UTC
Should be in UNCONFIRMED status as it hasn't been independently confirmed
Comment 4 tommy27 2013-06-24 15:10:43 UTC
@Joel
this is not a bug-report but rather an enhancement request for a feature which is not present in LibO.

just give a look yourself: the right-click autocorrect suggestions menu has no input field (see my mock screenshot), which I'm asking to add

is this enough to label this report as NEW?
Comment 5 tommy27 2013-07-18 12:00:00 UTC
setting it back as NEW.
I know this is not an indipendent confirmation, but anybody can easily see that such a feature does not yet exist in LibO.
Comment 6 Tomaz Vajngerl 2013-07-18 12:02:29 UTC
(In reply to comment #5)
> setting it back as NEW.
> I know this is not an indipendent confirmation, but anybody can easily see
> that such a feature does not yet exist in LibO.

Yes, this is not present in LibO.
Comment 7 Tomaz Vajngerl 2013-07-18 12:09:32 UTC
(In reply to comment #6) 
> Yes, this is not present in LibO.

I submitted too early.. What I wanted to say additionally is that adding a entry box into a pop-up menu is problematic. Only something like "add custom" could be added, which then triggers a dialog to enter a custom autocorrect entry. This is something that could be done easily.

Regards, Tomaž
Comment 8 tommy27 2013-07-18 12:24:24 UTC
(In reply to comment #7)
> (In reply to comment #6) 
> > Yes, this is not present in LibO.
> 
> I submitted too early.. What I wanted to say additionally is that adding a
> entry box into a pop-up menu is problematic. Only something like "add
> custom" could be added, which then triggers a dialog to enter a custom
> autocorrect entry. This is something that could be done easily.
> 
> Regards, Tomaž

it's not what I had in mind, but your proposal seems a good comprimise.
IMHO that "add custom" should stay at the bottom of the autocorrect suggestions list and should be separated by those words by an horizontal separator line.
Comment 9 tommy27 2013-07-18 19:36:13 UTC
... and it would be cool if after clicking the "add custom" the replacement table would open copying that word in the "replace field"
Comment 10 Kumāra 2013-08-24 03:33:08 UTC
(In reply to comment #7)
> I submitted too early.. What I wanted to say additionally is that adding a
> entry box into a pop-up menu is problematic. Only something like "add
> custom" could be added, which then triggers a dialog to enter a custom
> autocorrect entry. This is something that could be done easily.

Fully agree with this suggested solution. Also agree with the last two comments by tommy27.

The idea is clear now and workable. Now let's pray that an angel picks this up. :-)
Comment 11 tommy27 2013-09-11 04:50:20 UTC
as discussed in latest comments an "add custom" menu item triggering a dialog to insert a new autocorrect entry would be a good alternative solution if inserting an "entry box" in the pop-up menu is too complicated.

adding UI expert to CC list.
@Ivan
do you think it's something feasible?
Comment 12 tommy27 2015-09-25 12:24:55 UTC
thanks to the fix from Jay in Bug 92341 (target 5.1.0) there's no need to keep the current report open.

the original proposal was probably too complex to implement (see comment 7) and the current solution is a good compromise for me.

so I set status to WONTFIX