Download it now!
Bug 65992 - EDITING: Editing custom wordbook causes corruption
Summary: EDITING: Editing custom wordbook causes corruption
Status: RESOLVED DUPLICATE of bug 42122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 04:29 UTC by santiago473
Modified: 2013-06-30 13:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description santiago473 2013-06-21 04:29:54 UTC
Problem description: 

Deleting words from your custom wordbook corrupts your custom wordbook (file "standard.dic" in user-folder "wordbook").

Steps to reproduce:

1. Start with an empty wordbook -> empty user-folder "wordbook" or a "standard.dic" file that just contains the default entry:

OOoUserDict1
lang: <none>
type: positive
---

2. Open writer and type in the three words "herxherx" "hirxhirx" "harxharx"

3. Add the three words to your custom wordbook (right-click on each and choose "Add")

4. Now your "standard.dic" file should look like this:

OOoUserDict1
lang: <none>
type: positive
---
harxharx
herxherx
hirxhirx

5.1 Go to "Tools -> Options -> Language Settings -> Writing Aids -> User-defined dictionaries
-> "standard [All]" -> Edit", delete the first entry (harxharx), then click "close", then click "OK" (closing the Options-Menu) then close Writer

5.1.1 Your wordbook entry now looks like this (last entry doubled):

OOoUserDict1
lang: <none>
type: positive
---
herxherx
hirxhirx
hirxhirx

5.2 Go to "Tools -> Options -> Language Settings -> Writing Aids -> User-defined dictionaries
-> "standard [All]" -> Edit", delete the second entry (herxherx), then click "close", then click "OK" (closing the Options-Menu) then close Writer

5.2.1 Your wordbook entry now looks like this (last entry doubled):

OOoUserDict1
lang: <none>
type: positive
---
harxharx
hirxhirx
hirxhirx

5.3 Go to "Tools -> Options -> Language Settings -> Writing Aids -> User-defined dictionaries
-> "standard [All]" -> Edit", delete the last entry (hirxhirx), then click "close", then click "OK" (closing the Options-Menu) then close Writer

5.3.1 Your wordbook entry now looks like this (nothing got deleted):

OOoUserDict1
lang: <none>
type: positive
---
harxharx
herxherx
hirxhirx

Current behavior:

Deleting an entry (expect last) doubles last entry; deleting last entry is not working.

Expected behavior:

Deleting "harxharx" should result in:

OOoUserDict1
lang: <none>
type: positive
---
herxherx
hirxhirx

Deleting "herxherx" should result in:

OOoUserDict1
lang: <none>
type: positive
---
harxharx
hirxhirx

Deleting "hirxhirx" should result in:

OOoUserDict1
lang: <none>
type: positive
---
harxharx
herxherx

Operating System: Windows XP SP3
LibreOffice Version: 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)
Operating System: Windows XP
Version: 4.0.4.2 release
Comment 1 manj_k 2013-06-22 21:15:19 UTC
See also: Bug 42122 - Deleting entries from user-defined dictionaries does not work properly

(Duplicate?)
Comment 2 tommy27 2013-06-23 11:15:42 UTC
look like a duplicate to me too. closing this bug report.

a fix is already available in the 4.1.x branch, not yet backported into 4.0.x

*** This bug has been marked as a duplicate of bug 42122 ***
Comment 3 santiago473 2013-06-30 13:29:37 UTC
(In reply to comment #1)
> See also: Bug 42122 - Deleting entries from user-defined dictionaries does
> not work properly
> 
> (Duplicate?)

You are right, seems like this is the same issue.

Although I cannot confirm the fix from Michael Meeks since the current beta of LibreOffice 4.1.0.1.0 (Build ID: 8a1cc1449c26b7b5a46f258aabf13c28a9dbebb) crashes after closing if you have created an user-dictionary by adding a new word (like "herxherx").