Bug 66009 - Crash, when inserting https URL
Summary: Crash, when inserting https URL
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All Linux (All)
: high major
Assignee: Stephan Bergmann
URL:
Whiteboard:
Keywords:
: 66094 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-06-21 13:53 UTC by Thomas Hackert
Modified: 2013-07-10 06:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
valgrind log (18.32 KB, text/plain)
2013-07-09 15:26 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2013-06-21 13:53:26 UTC
Hello @ll,
I hope, I have chosen the right component. If I am wrong here, feel free to change it ... ;)

Steps to reproduce:
1. Start Writer
2. Open https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg in your browser
3. Rightclick on it and choose "Copy image" (or so ... ;) I am using Firefox as well as LO with a Germanophone UI and Help ... ;) )
4. In Writer: Press <Ctrl>+<Shift>+<V>
5. Choose "HTML (HyperText Markup Language)" in "Paste Special" window

LO immediatly crashes ... :(

LO: Version: 4.1.0.1 w/ installed Germanophone lang- as well as helppack
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155
OS: Debian Testing AMD64

This works with my installed LO Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2), so I am not sure, if I should set this bug to regression ... :( If someone else can confirm, that it works for him in 4.0.x as well, feel free to set this bug as a regression ... ;)

Sorry for the inconvenience
Thomas.
Comment 1 Thomas van der Meulen 2013-06-21 14:01:59 UTC
Thank you for your bug report, I CAN'T reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4.
Comment 2 Joel Madero 2013-06-21 17:43:31 UTC
Confirmed - I think it's user error since it's inserting a jpeg as HTML BUT LibreOffice should probably spit out an error instead of crashing and ideally offer an option to insert image if it's an image extension


Marking as:

New
Major - crash
High - default seems appropriate
Comment 3 Caolán McNamara 2013-06-27 16:01:15 UTC
some terrifying crash in neon/ssl, I bet it open happens with https urls and not http
Comment 4 Caolán McNamara 2013-07-02 19:55:06 UTC
caolanm->mstahl: is this fixed by 49a454225e35699d7351faaba3d296e1858c6107 this has presumably got to be a duplicate of bug #66324
Comment 5 Michael Stahl (CIB) 2013-07-02 20:25:05 UTC
no idea, it doesn't crash here in any version i tried,
downloads loads of SSL certs and then says "Server certificate verification failed: issuer is not trusted", doesn't show picture just empty frame
Comment 6 Caolán McNamara 2013-07-09 15:26:15 UTC
Created attachment 82238 [details]
valgrind log
Comment 7 Caolán McNamara 2013-07-09 15:38:12 UTC
I reckon this was fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=b7cf9c7b933fdc2dcd61e59c0022a066a8717b27
Comment 8 Caolán McNamara 2013-07-09 15:51:32 UTC
*** Bug 66094 has been marked as a duplicate of this bug. ***