Bug 66034 - Crash on using "=" in a cell
Summary: Crash on using "=" in a cell
Status: RESOLVED DUPLICATE of bug 62155
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-22 04:41 UTC by jaiswal
Modified: 2013-06-24 10:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Crash report (88.94 KB, text/plain)
2013-06-24 10:10 UTC, jaiswal
Details
Screen shot of Extension manager (123.79 KB, image/png)
2013-06-24 10:11 UTC, jaiswal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jaiswal 2013-06-22 04:41:49 UTC
I am using LibreOffice_4.0.2_MacOS_x86 on a MAC pro running MacOS-Lion. I have been observing that with upgrade to either LibreOffice_4.0.3_MacOS_x86 or LibreOffice_4.0.4_MacOS_x86, LibreOffice crashes if I open a spreadsheet (Calc) and type equal (=) sign in a cell. Hence I had to downgrade to LibreOffice_4.0.2_MacOS_x86 after the upgrade to both.
Comment 1 GerardF 2013-06-22 07:24:06 UTC
Make a try with a new profile.
Did you have extensions installed (numbertext ?) ?
Comment 2 Julien Nabet 2013-06-22 11:08:20 UTC
The bug has been solved in 4.0.3.
Since you encountered the problem when you ugraded from 4.0.2 to 4.0.3 it's normal. (even if you upgraded from 4.0.3 to 4.0.4 afterwards)

*** This bug has been marked as a duplicate of bug 62155 ***
Comment 3 jaiswal 2013-06-22 12:47:01 UTC
(In reply to comment #1)
> Make a try with a new profile.
> Did you have extensions installed (numbertext ?) ?

Yes, I had extensions installed. I removed numbertext, which was anyway showing error in extension manager, and now the problem is solved.
Thanks a lot.
Comment 4 Michael Meeks 2013-06-24 08:49:57 UTC
Interesting - I'd really like to get more details on that ! :-)

What error was numbertext showing in the extension mgr ? do you remember ? and/or can you reproduce that by moving your profile back ?

There is some fundamental / underlying problem we're trying to zero in on here - despite having a band-aid for this at the calc level in newer releases....
Comment 5 jaiswal 2013-06-24 10:10:47 UTC
Created attachment 81322 [details]
Crash report
Comment 6 jaiswal 2013-06-24 10:11:36 UTC
Created attachment 81323 [details]
Screen shot of Extension manager
Comment 7 jaiswal 2013-06-24 10:16:00 UTC
I reinstalled "numbertext-0.9.4.oxt" and again LibreOffice started crashing as soon as the key "=" was pressed for formula. The crash report text file and the screenshot of the Extension Manager is attached above. Removing the extension has resolved the issue again.

Regards,
Uttam

(In reply to comment #4)
> Interesting - I'd really like to get more details on that ! :-)
> 
> What error was numbertext showing in the extension mgr ? do you remember ?
> and/or can you reproduce that by moving your profile back ?
> 
> There is some fundamental / underlying problem we're trying to zero in on
> here - despite having a band-aid for this at the calc level in newer
> releases....