Bug 66070 - Several Greek characters are not displayed correctly with the fonts Calibri and Cambria
Summary: Several Greek characters are not displayed correctly with the fonts Calibri a...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-23 08:03 UTC by Andreas Tsourouflis
Modified: 2013-07-06 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (comparison Times New Roman, Calibri and Cambria) (64.71 KB, image/png)
2013-06-24 18:35 UTC, Andreas Tsourouflis
Details
Greek text in .odt format containing the characters under consideration (14.13 KB, application/vnd.oasis.opendocument.text)
2013-06-26 12:42 UTC, Andreas Tsourouflis
Details
Screenshot from LO 4.1 (133.88 KB, image/png)
2013-07-05 19:53 UTC, Andreas Tsourouflis
Details
New sample text (9.88 KB, application/vnd.oasis.opendocument.text)
2013-07-05 21:46 UTC, Andreas Tsourouflis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Tsourouflis 2013-06-23 08:03:02 UTC
The following Greek characters are not displayed correctly with the fonts Calibri and Cambria:
Ά (U+0386)
Έ (U+0388)
Ή (U+0389) 
Ί (U+038Α)
Ό (U+038C)
Ύ (U+038E)
Ώ (U+038F)
ΐ (U+0390)
With other fonts there is no problem.
This has been appearing in all Linux versions since 4.0 (distros used: Ubuntu, Fedora, Mageia, OpenSuse).
The same characters are correctly displayed in Windows versions.
Comment 1 Khaled Hosny (inactive) 2013-06-24 18:20:32 UTC
Please attach screenshot of the rendering of those characters.
Comment 2 Andreas Tsourouflis 2013-06-24 18:35:31 UTC
Created attachment 81352 [details]
Screenshot (comparison Times New Roman, Calibri and Cambria)
Comment 3 Khaled Hosny (inactive) 2013-06-24 19:44:24 UTC
I can not reproduce this in master, but I don’t have 4.0 installation to compare with.
Comment 4 retired 2013-06-25 22:10:15 UTC
Andreas, could you attach an example LO writer document (the one used to create the sceenshot) so others can easily use that document for further testing?

Thanks :)
Comment 5 Andreas Tsourouflis 2013-06-26 12:42:07 UTC
Created attachment 81469 [details]
Greek text in .odt format containing the characters under consideration
Comment 6 Andreas Tsourouflis 2013-06-26 12:47:22 UTC
I attached a text file with the characters not rendered correctly. Please note that the document format is irrelevant. The same bug appears also in .doc files. 

The document was created with LO 4.0.0.3 (Windows version), therefore at the time that I created this file, I could not see any difference in the rendering
Comment 7 Khaled Hosny (inactive) 2013-06-29 20:26:57 UTC
I cannot reproduce this issue with master, even with the attached file.
Comment 8 retired 2013-07-03 12:36:36 UTC
WORKSFORME.

Using Ubuntu 13.04, LO 4.1.0.1.

Andreas: Please re-try using LO 4.1.0.1 http://www.libreoffice.org/download/pre-releases/. Should the bug still happen in that version please re-open this bug.

Thanks :)
Comment 9 Andreas Tsourouflis 2013-07-05 19:53:16 UTC
Created attachment 82090 [details]
Screenshot from LO 4.1

Sorry guys, but the problem doesn't seem to be solved in Libreoffice 4.1
I attach a screenshot from Libreoffice 4.1 running on OpensSuse 12.3.
Anyway, thanks for your efforts
Comment 10 Khaled Hosny (inactive) 2013-07-05 20:11:58 UTC
What version of Callibri font do you have? Might be a font issue. 5.62 here.
Comment 11 Andreas Tsourouflis 2013-07-05 20:43:46 UTC
Font Viewer reports version 1.02 from 2006. I have somewhere a newer Windows disk lying. I will try it and I will report back..
Comment 12 Andreas Tsourouflis 2013-07-05 21:29:20 UTC
I have used Calibri version 5.62 and Cambria version 5.93. 

The problem is almost solved. I say almost, because the characters are rendered correctly, except when:
(a) they are used adjacently, i.e. next to each other.
(b) there is one space between them

If there are two or more spaces between them or another character, then they are rendered correctly.
Comment 13 Andreas Tsourouflis 2013-07-05 21:46:43 UTC
Created attachment 82096 [details]
New sample text

I attach a new sample text. This time, I think you will be able to reproduce the bug. 

It seems that the problem is related to the font version, although the same font is rendered correctly in Windows versions of LO or in Linux versions prior to 4.0.

Finally, I would like to note that with newer versions of Calibri and Cambria the problem appears only when the characters under discussion are used next to each other. In real life, this may happen only rarely. Therefore, the practical impact of this bug is significantly reduced. If you believe that this bug should be marked as resolved, I have no objection.

Thank you :)
Comment 14 Khaled Hosny (inactive) 2013-07-06 08:06:36 UTC
That is by design. The font has contextual substitutions that drop tone marks for Greek uppercase when followed by other uppercase letters. This does not happen on Windows because we don’t enable OpenType features for Greek text there, unlike on Linux or Mac.