Bug Hunting Session
Bug 66078 - SPELL: Comments in partial words break spell check
Summary: SPELL: Comments in partial words break spell check
Status: RESOLVED DUPLICATE of bug 45347
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-23 12:53 UTC by Rune Juhl Jacobsen
Modified: 2013-06-24 13:24 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
An example of the spell checker incorrectly marking a correctly spelled word as being incorrect. (34.03 KB, image/png)
2013-06-23 12:53 UTC, Rune Juhl Jacobsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rune Juhl Jacobsen 2013-06-23 12:53:20 UTC
Created attachment 81266 [details]
An example of the spell checker incorrectly marking a correctly spelled word as being incorrect.

Problem description: Placing a comment half-way into a word breaks the spell checker, as the corresponding word is seen as segmented on the comment selection borders.
First noted in LibreOffice 4.0.2.2 on Ubuntu 13.04.

Steps to reproduce:
1. Write text with correct spelling
2. Place a comment so that it begins/ends inside a correctly spelled word.

Current behavior: The word is segmented at the comment (if no selection) or on the comment selection borders.

Expected behavior: Spell check should ignore all comments.

              
Operating System: Ubuntu
Version: unspecified
Comment 1 Jorendc 2013-06-24 13:24:43 UTC

*** This bug has been marked as a duplicate of bug 45347 ***