Bug 66083 - libreoffice base crashes executing macro
Summary: libreoffice base crashes executing macro
Status: RESOLVED DUPLICATE of bug 64279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-23 14:51 UTC by Willem Samyn
Modified: 2013-06-27 16:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Willem Samyn 2013-06-23 14:51:54 UTC
Hello,

I tried to create a database with LibreOffice. It contains some macros. When starting the database I am first prompted to enable the macros. Then I get a form, containing several buttons. Most buttons activate macros that print a report. These reports are based on queries. I have created the database for someone who only uses Windows 8.

Now here is my problem:

I have created and tested the database in Windows Vista. Sometimes everything goes well, and sometimes not. The reason is not clear, because sometimes there is nothing changed and the next time it goes wrong again. I tried LibreOffice 4.03, 4.04 and 3.6, all versions with both JRE 1.6.0_22 and 1.7.0_25. One time everything works, sometimes the database crashes, after clicking a button to print a report. When using LO 3.6 and 4.0.3 the database seems to freeze (not responding) so I have to close LO and start again, each time with the message that the database must be restored. After this recovery than it will work again, even without something been changed. With LO 4.0.4 I get a window to restore the database immediately after clicking the same button. Then I start again to restore. After that I reopen the database and after clicking the same button I get the same window to restore the database.

When tested under Linux, I have had no crashes yet. Mageia with LO 4.0.3 and openSUSE with LO 3.6.
Using Windows and Apache OO there seems to be no such bug.
Comment 1 Willem Samyn 2013-06-23 15:48:32 UTC
After some more testing I can tell you now that it's not the macro that triggers the bug.
Everytime I choose to make a report directly (not using the macro), the database crashes.
The queries doesn't cause any problems.
Comment 2 Robert Großkopf 2013-06-23 16:55:03 UTC
The report-builder doesn't work in LO 4.0.4. It will be fixed in Version LO 4.0.5.

*** This bug has been marked as a duplicate of bug 64279 ***
Comment 3 Lionel Elie Mamane 2013-06-23 18:43:56 UTC
FYI, this particular crash also does not exist in 4.0.3, so you can either take a daily build of 4.0.5.beta or go back to 4.0.3.
Comment 4 Willem Samyn 2013-06-27 16:59:46 UTC
I tried the daily build 4.1 2013-06-27 and I stil have the same problem.
Reports don't work. I go directly to a window "Document Recovery".