Bug Hunting Session
Bug 66093 - FILEOPEN: MS .docx Fails to import properly. Indent, placement, and chart errors
Summary: FILEOPEN: MS .docx Fails to import properly. Indent, placement, and chart errors
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-23 16:47 UTC by Luke
Modified: 2013-09-22 18:53 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
MS .docx file fails to import correctly (172.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-23 16:47 UTC, Luke
Details
Comparison of Doc in Word vs Writer P1 (333.74 KB, image/png)
2013-06-23 16:53 UTC, Luke
Details
Comparison of Doc in Word vs Writer P2 (288.78 KB, image/png)
2013-06-23 16:54 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-23 16:47:09 UTC
Created attachment 81273 [details]
MS .docx file fails to import correctly

This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS .docx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-Hayden-Management.docx document in writer 
2. Open attached Demo-Hayden-Management.docx document in Word2003/Office 365
3. Compare the documents. 

There 3 major areas where the import fails. 

1) Picture is missing
2) Picture is placed on left side instead of the right.
3) Chart is rendered incorrectly
4) Chart is missing
5) West is missing from chart
Comment 1 Luke 2013-06-23 16:53:53 UTC
Created attachment 81274 [details]
Comparison of Doc in Word vs Writer P1

See original post for description of errors
Comment 2 Luke 2013-06-23 16:54:31 UTC
Created attachment 81275 [details]
Comparison of Doc in Word vs Writer P2

comparison page 2
Comment 3 Thomas van der Meulen 2013-06-23 17:35:10 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4. 

It also looks like there are with strips true the lines of text.
Comment 4 Luke 2013-06-29 16:54:26 UTC
The developers asked that I split up bug reports like this, so I created 6 new ones, 66368 - 66373 

You can close this or make it a meta bug to track the separate issues.