Download it now!
Bug 66112 - Comments cause top ruler to display wrong in some cases
Summary: Comments cause top ruler to display wrong in some cases
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 08:13 UTC by Nico Dorn
Modified: 2014-09-22 14:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Image #1 (59.93 KB, image/png)
2013-06-24 08:14 UTC, Nico Dorn
Details
Image #2 (57.28 KB, image/png)
2013-06-24 08:15 UTC, Nico Dorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Dorn 2013-06-24 08:13:01 UTC
The bug depends on the cursor position (see image #2).

To reproduce the bug:
1) Open an empty document.
2) Type a short sentence.
3) Add a comment to one of the words.
4) Move the cursor to the "hidden space" which marks the end of the comment
Comment 1 Nico Dorn 2013-06-24 08:14:14 UTC
Created attachment 81306 [details]
Image #1

no bug, watch the position of the cursor!
Comment 2 Nico Dorn 2013-06-24 08:15:07 UTC
Created attachment 81307 [details]
Image #2

bug, the comment has the focus
Comment 3 Eugene 2013-06-24 19:58:48 UTC
I can't reproduce this bug in Libreoffice 4.1.0.1 rc on Ubuntu 13.04 x64 with GTK theme. Maybe this issue occurs only with Oxygen theme?
Comment 4 Nico Dorn 2013-06-25 10:48:02 UTC
I tested it again, now using Raleigh as GTK2 Theme. Same result for me.

It's very important that the cursor is at the right position as described in #c1. Otherwise the bug's not triggered.
Comment 5 Jacques Guilleron 2013-06-25 15:51:49 UTC
Hello Nico,

I reproduce this behaviour with master LO 4.2.0.0.alpha0+
Build ID: ce0383d2950d3b0da2c457c8a406c1229de53571 & Windows 7 Home Premium. 
But I have to select the very thin space behind the word to get it. 
In this case, Comments button is moved to the left side of the ruler, which is displayed without boundary on the right side.
Moving the cursor in another place give again the right behaviour for ruler.
So I set status for this report to NEW, Platform to All and minorize Importance to LOW TRIVIAL because it doesn't prevent to make high quality work.

Thank you for reporting.
Have a nice day,

Jacques Guilleron
Comment 6 Nico Dorn 2013-08-30 09:26:29 UTC
Just another oberservation in 4.1.1: The bug only appears on comments with text range.
Comment 7 Nico Dorn 2014-09-22 14:50:44 UTC
I think that the bug has been fixed automagically. At least I cannot reproduce it anymore with LO 4.3.1.2.