Download it now!
Bug 66113 - LO 4.1RC2 DEB packages install with uid:group 500:500
Summary: LO 4.1RC2 DEB packages install with uid:group 500:500
Status: RESOLVED DUPLICATE of bug 67388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 08:31 UTC by Nico Dorn
Modified: 2013-08-07 15:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
attachment #1 (installation errors) (1.77 KB, text/plain)
2013-06-24 08:32 UTC, Nico Dorn
Details
attachment #2 (error message at startup) (39.87 KB, image/png)
2013-06-24 08:32 UTC, Nico Dorn
Details
messages during the installation (13.11 KB, text/plain)
2013-07-02 18:15 UTC, Nico Dorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Dorn 2013-06-24 08:31:20 UTC
To reproduce the bug:
1. Download the deb-packages from the LO website (http://www.libreoffice.org/download/pre-releases/)
2. Extract and install them with "dpkg -i *.deb" (or whatever commands appropriate for your system)

Errors:
- There are some error messages at the end of the installation regarding the kde integration (see attachment #1).
- Nevertheless, there are icons for LO 4.1 in the start menu. But clicking them has no effect.
- Entering the command of the starters ("libreoffice4.1 --writer %U") in the console leads to an error message (see attachment #1).

=> LO does not start.

Work around:
Stripping the "%U" from the starter helps.
Comment 1 Nico Dorn 2013-06-24 08:32:01 UTC
Created attachment 81308 [details]
attachment #1 (installation errors)
Comment 2 Nico Dorn 2013-06-24 08:32:39 UTC
Created attachment 81309 [details]
attachment #2 (error message at startup)
Comment 3 Nico Dorn 2013-06-24 11:30:30 UTC
I investigated the bug further. I think the problem are the starters (i.e. desktop-files) in the folder LO-ROOT/share/xdg. They belong to user and group 500. Changing them to root ("sudo chmod root.root *") fixes the bug.

Compare the file listing in LO 4.0:
-rw-r--r-- 1 root root 30795 Jun 12 00:38 base.desktop
-rw-r--r-- 1 root root 24520 Jun 12 00:38 calc.desktop
-rw-r--r-- 1 root root 23176 Jun 12 00:38 draw.desktop
-rw-r--r-- 1 root root 27183 Jun 12 00:38 impress.desktop
-rw-r--r-- 1 root root  7517 Jun 12 00:38 javafilter.desktop
-rw-r--r-- 1 root root 21999 Jun 12 00:38 math.desktop
-rw-r--r-- 1 root root  7498 Jun 12 00:38 printeradmin.desktop
-rw-r--r-- 1 root root  1019 Jun 12 00:38 qstart.desktop
-rw-r--r-- 1 root root 23147 Jun 12 00:38 startcenter.desktop
-rw-r--r-- 1 root root 29246 Jun 12 00:38 writer.desktop
-rw-r--r-- 1 root root  5145 Jun 12 00:38 xsltfilter.desktop

And LO 4.1:
-rw-r--r-- 1  500  500 27001 Jun 19 01:57 base.desktop
-rw-r--r-- 1  500  500 24084 Jun 19 01:57 calc.desktop
-rw-r--r-- 1  500  500 20484 Jun 19 01:57 draw.desktop
-rw-r--r-- 1  500  500 23955 Jun 19 01:57 impress.desktop
-rw-r--r-- 1  500  500 19327 Jun 19 01:57 math.desktop
-rw-r--r-- 1  500  500  1078 Jun 19 01:57 qstart.desktop
-rw-r--r-- 1  500  500 23279 Jun 19 01:57 startcenter.desktop
-rw-r--r-- 1  500  500 26115 Jun 19 01:57 writer.desktop
-rw-r--r-- 1  500  500  5223 Jun 19 01:57 xsltfilter.desktop
Comment 4 Greg 2013-07-02 17:32:48 UTC
@Nico - I believe the install command needs to be run as 'root', so your install line should read: 

sudo dpkg -i *.deb

If you don't install as root I would expect that the shortcut ownerships would be messed up.



/Greg
Comment 5 Nico Dorn 2013-07-02 18:14:35 UTC
Thanks for your answer Greg! At first I thought that I really forgot to prepend the "sudo", save I installed LO many times that way. So I did the whole routine once again and made a clean installation of LO 4.1.0.1 RC after uninstalling the old one. (I made sure that the program folder was gone.)

The outcome is actually the same. But your comment opend my eyes, that not only the starters, but every folder and every file is installed with user & group 500:

nico@Abulafia2:/opt/libreoffice4.1$ ls -l
total 1264
-rwxr-xr-x  1 500 500  59934 Jun 19 01:57 CREDITS.odt
drwxr-xr-x  2 500 500   4096 Jul  2 19:56 help
-rw-r--r--  1 500 500 436216 Jun 19 01:57 LICENSE
-rw-r--r--  1 500 500 603074 Jun 19 01:57 LICENSE.html
-rwxr-xr-x  1 500 500 141186 Jun 19 01:57 LICENSE.odt
-rwxr-xr-x  1 500 500   4907 Jun 19 01:57 NOTICE
drwxr-xr-x  9 500 500   4096 Jul  2 19:56 presets
drwxr-xr-x  9 500 500  16384 Jul  2 19:56 program
drwxr-xr-x  2 500 500   4096 Jul  2 19:56 readmes
drwxr-xr-x 23 500 500   4096 Jul  2 19:56 share
drwxr-xr-x  5 500 500   4096 Jul  2 19:56 ure
lrwxrwxrwx  1 500 500      3 Jun 19 01:57 ure-link -> ure

(I will attach another text file with all the installation messages including the errors on line 172 following.)

I won't overestimate it, but isn't that a RELEASE BLOCKER?
Comment 6 Nico Dorn 2013-07-02 18:15:24 UTC
Created attachment 81902 [details]
messages during the installation
Comment 7 Ruslan Kabatsayev 2013-07-11 17:27:59 UTC
Can easily reproduce. This shouldn't get released until fixed, so setting severity to blocker.
Comment 8 Ruslan Kabatsayev 2013-07-11 17:37:09 UTC
Have to notice that this seems to happen with both x86 and AMD64 packages.

Someone please also check RPM packages, maybe they are affected too.
Comment 9 Urmas 2013-07-12 09:43:05 UTC
Not a blocker as it doesn't affect functionality and affects insignificant part of users.
Comment 10 Nico Dorn 2013-07-12 17:41:01 UTC
Because I assume the bug will not get fixed until the .0-Release of LO 4.1, I post the WORKAROUND for all those affected on Ubuntu like systems. After installing the packages run:

sudo chown -R root:root /opt/libreoffice4.1
Comment 11 Bugzilla 2013-07-26 18:35:47 UTC
This still happens with AMD64 deb packages in Libreoffice 4.1.0.4.
Comment 12 Nico Dorn 2013-08-07 14:18:50 UTC
Duplicate of the later reported and now fixed Bug 67388.
Comment 13 Nico Dorn 2013-08-07 14:19:05 UTC

*** This bug has been marked as a duplicate of bug 67388 ***