Bug Hunting Session
Bug 66128 - FORMATTING: Formatting Toolbars Interfere with Find Search
Summary: FORMATTING: Formatting Toolbars Interfere with Find Search
Status: RESOLVED DUPLICATE of bug 55855
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 15:14 UTC by jonnjones
Modified: 2013-11-20 16:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
An example you can search through. (12.81 KB, application/vnd.oasis.opendocument.text)
2013-06-24 15:14 UTC, jonnjones
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonnjones 2013-06-24 15:14:27 UTC
Created attachment 81347 [details]
An example you can search through.

Problem description: Bullets and Numbering, Tables, and other Formatting Toolbars interfere while using the Find Toolbar at the bottom of the window. Numerous times I've searched for a word and, while searching, a Formatting Toolbar appears below the Find Toolbar, pushing the Find Toolbar up. This results in accidentally pushing a formatting button because the mouse pointer is still hovering over the location where the search-next button used to be.

This has been a constant problem throughout numerous papers I've worked on using LibreOffice, making huge messes out of hours of work. It's a good thing there's undo.

Steps to reproduce:
1. Make a new writer document and put random words in it. Include the same word in regular text, in a table, and in a numbered/bullet-ed list.
2. Use the Find Toolbar to find that repeated word throughout the text.
3. Observe how the search toolbar is displaced by other toolbars while searching through the differently-formatted areas.

Current behavior: The Find Toolbar is displaced by various other toolbars while searching.

Expected behavior: The search toolbar should stay absolutely still, in the exact same location, while searching, displaced by absolutely nothing. I'm guessing it should probably always stay at the very bottom of all toolbars, no matter how many appear.

              
Operating System: Linux (Other)
Version: 4.0.4.2 release
Comment 1 Jorendc 2013-06-24 22:57:13 UTC

*** This bug has been marked as a duplicate of bug 55855 ***