Download it now!
Bug 66162 - printf string displayed as '$(ARG1)'
Summary: printf string displayed as '$(ARG1)'
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-25 16:07 UTC by Tadele Assefa
Modified: 2015-05-17 12:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A dialog with the message. (3.29 KB, image/png)
2013-06-25 16:07 UTC, Tadele Assefa
Details
WOrd file which shows $(ARG1) (177.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-30 19:17 UTC, Tadele Assefa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tadele Assefa 2013-06-25 16:07:38 UTC
Created attachment 81417 [details]
A dialog with the message.

In LibreOffice
Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155

When I try to open a corrupted word 2007 file using LibreOffice, one of the Dialogs  that explains the error has a string that reads 'The file '$(ARG1) could not be repaired and therefore cannot be opened.'
Comment 1 Andras Timar 2013-06-28 20:42:48 UTC
Can you please attach a corrupted Word doc here?
Comment 2 Tadele Assefa 2013-06-30 19:17:33 UTC
Created attachment 81755 [details]
WOrd file which shows $(ARG1)
Comment 3 Tadele Assefa 2013-06-30 19:39:25 UTC
(In reply to comment #1)
> Can you please attach a corrupted Word doc here?

Dear Andras,

Attached is the file which cased the stated message. This is on Windows 7, x64. How I got to this:
1) while editing the file MS Word 2007, my PC was shutdown improperly and the file got corrupted.
2) when I try to open using Word, it said, the file is corrupt. Then i clicked the "Details" button it reads, "> is missing at line 2, col 42377".
3) I tried to open in LO 4.1 and it said "Cannot Open. General input/output error."
4) I opened the file in Notepad++ and added > at end of line 2(just ignoring the big column stated)
4) Word still does not open it.
5) Tried toopen in LO 4.1, and got the message.
Comment 4 Andras Timar 2013-07-01 07:46:35 UTC
Confirmed with LibreOffice 4.1 (own build).
Comment 5 Julien Nabet 2013-07-02 21:39:18 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.
(so not Windows only)
Comment 6 Julien Nabet 2013-07-02 21:40:26 UTC
I had another popup afterwards indicating this:
Id 3878 only handled by SimpleErrorHandler
ErrorCode: 38
ErrorClass: 15
ErrorArea: 0
Comment 7 Marcos Souza 2013-08-13 17:52:22 UTC
This is my last commit:

commit cc569401a45e7977aed2aa169b2e2c86d2f06da4
Author: Andrzej J.R. Hunt <andrzej@ahunt.org>
Date:   Sun Aug 11 23:56:36 2013 +0100

    Tables header fixes.
    
    Change-Id: Id0d29ca4424e956489b4736c92605e5b1546a951

I could not reproduce this error.
Comment 8 Julien Nabet 2014-04-10 19:06:23 UTC
On pc Debian x86-64 with master sources updated today, I got a pop with general input/output error and on console this:
:1: parser error : Document is empty
Comment 9 Gordo 2015-05-17 12:31:27 UTC
From comment 3 I take it to mean that the file was corrupted by Word and not LO.

I tried to extract the content xml file, which was the only file, using 7zip but it failed with CRC error.

Changed to RESOLVED INVALID.