Bug 66194 - FILESAVE: Animation effects on SVG graphics lost upon re-load
Summary: FILESAVE: Animation effects on SVG graphics lost upon re-load
Status: RESOLVED DUPLICATE of bug 64512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-26 07:44 UTC by lechten
Modified: 2013-07-14 03:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Presentation in odp format without animations on SVG graphics (398.43 KB, application/vnd.oasis.opendocument.presentation)
2013-06-26 07:44 UTC, lechten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lechten 2013-06-26 07:44:43 UTC
Created attachment 81449 [details]
Presentation in odp format without animations on SVG graphics

Problem description: 
I'm adding animations via "Add->Appear" to SVG graphics. They work fine while editing. After saving, closing, and re-loading the document, those animations are gone (animations on other objects such as text, lines, rectangles work fine.)
Note: I filed this bug under Ubuntu, but it also affects Windows XP.

Steps to reproduce:
1. Open attached document.
2. Slide Show -> Custom Animation
3. Select first padlock graphics on Slide 1.
4. “Add” animation “Entrance->Appear”.
5. (Observe that “SVG 2” has been appended to the animation list, as expected.)
6. Press F5 to view the slide.  Notice that the padlock graphics is not visible initially (as the animation is working correctly).
7. (Optionally, spend lots of time to have all graphics appear in the correct order.)
8. Save, close, and re-open the document, press F5, notice that all animations concerning graphics are lost.

Current behavior:
The animations are gone when loading the document.
(A workaround: Create filled white rectangles that cover the graphics.  Add animations “Exit->Disappear” that remove those rectangles in the correct order to have the previously covered graphics become visible again.
Drawback: If you print the slides or export them to PDF, the graphics won’t be visible.)

Expected behavior:
The animations still work when loading the document.

Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 ign_christian 2013-07-14 02:56:23 UTC
Reproducible on LO 4.0.4.2 (Win7 32bit), such animation lost after closing & reopening.
Comment 2 ign_christian 2013-07-14 03:11:35 UTC
Same as Bug 64512 -> problem with filesave on ODP, not happen if saving as PPT

*** This bug has been marked as a duplicate of bug 64512 ***