Bug 66203 - FORMATTING: Heading levels in docx format
Summary: FORMATTING: Heading levels in docx format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-26 11:55 UTC by Paul B
Modified: 2016-09-20 11:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file with personnal style My-Heading, Outline = Level 1 (7.54 KB, application/vnd.oasis.opendocument.text)
2013-10-22 12:32 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul B 2013-06-26 11:55:46 UTC
Steps to reproduce:
1. Create custom heading style
2. Assign a heading level to that style under "outline and numbering"
3. Save the document in docx format, then close the document
4. Re open the document. The heading style will have reverted to a default body text level, so when you try to view your headings in the organiser none will show.

I wouldn't worry too much about this except that I have to use the docx format for Android compatibility - as far as I know there isn't an Android office suite that can handle Open Doc formats ... 

Current behavior:

Expected behavior:

              
Operating System: Windows 8
Version: 4.0.4.2 release
Comment 1 Zoltan Laszlo 2013-07-05 16:04:06 UTC
Could not reproduce on LibreOffice 4.1.0.1 and Win7 Home Premium x64.
Comment 2 Paul B 2013-07-06 17:10:28 UTC
I was using Windows 8 but have reverted to Win7 (x64)- so I have a clean OS install but I'm still have the same problem (also using LO 4.1). I thought it might be because I have been using a customised default template which was first created in an older version of LibreOffice - so I tried reverting to the standard "text document" template but it has made no difference.
Comment 3 Laurent BP 2013-10-22 12:30:55 UTC
Hi,

I can confirm with Version: 4.1.3.1
Build ID: b42498da0e3f91b17e51b55c8295ec4f8f22087

Open Attachment. Check My-Heading style. With OpenDocument format, Outline is Level 1. Save it in DOCX and reload
=> My-Heading Outline is now Body text

Moreover, there is now TWO empty paragraph, instead of ONE, but this may be another bug.
Comment 4 Laurent BP 2013-10-22 12:32:59 UTC
Created attachment 87981 [details]
Test file with personnal style My-Heading, Outline = Level 1
Comment 5 Jorendc 2014-04-21 23:24:02 UTC
@Laurent: You mind retesting using version Version: 4.3.0.0.alpha0+
Build ID: 619b4c40da9e85febbb08a3f7cf8aa8d10963fc1
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-18_00:07:53
or newer?

I think I fail to reproduce the heading level outline issue.

Kind regards,
Joren
Comment 6 Laurent BP 2014-04-22 11:25:45 UTC
I can reproduce with Version: 4.1.5.3
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
with Version: 4.1.6.1
Build ID: a59ce81388f477fc89db57f0c27f222f31884eb

I can NOT reproduce with Version: 4.2.1.0.0+
Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c

I can NOT reproduce with Version: 4.2.3.3
Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0

I can NOT reproduce with Version: 4.3.0.0.alpha1+
Build ID: 4916dd570fb7bb5447f1d63fba46ac0b3a10dd14
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-20_03:53:39

So the bug was fixed in 4.2

However export to DOC files is still bugous
Comment 7 meneerjansen00 2015-05-12 17:45:23 UTC
Seems like a duplicate of a certain bug w/ outline numbering and MS .doc(x): https://bugs.documentfoundation.org//show_bug.cgi?id=50774
Comment 8 QA Administrators 2016-09-20 09:42:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920