Bug Hunting Session
Bug 66248 - odp export to PPTX corrupted according to PowerPoint2010
Summary: odp export to PPTX corrupted according to PowerPoint2010
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.1.3.2:OSX10.9 NoRepro:4.3...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-27 09:38 UTC by Clemens Eisserer
Modified: 2013-12-13 11:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-06-27 09:38:40 UTC
Hi,

When exporting the attached LibreOffice-Presentation to PPTX-Format, several things seem to go wrong:

- When openning the document, Powerpoint complains that the file is corrupt and offers to repair it. During the repair process it reports that it removed some content.

- Charts are almost always completely garbled. Funny thing is, the charts look ok when the pptx-file is opened with LibreOffice.

The export to PowerPoint97 seems to work a lot better. Although charts are saved as images, the file is not corrupt and can at least be viewed with PP2010.
Comment 1 bfoman (inactive) 2013-06-27 10:20:25 UTC
Please reattach as there is no attachment in your bug report.
Comment 2 Clemens Eisserer 2013-06-27 10:24:15 UTC
The 3MB file size limit is a real restriction unfortunately.

I've uploaded the files at a free hoster now.
Please find the odp file at: https://mega.co.nz/#!9pUFzRAR!L2HFUSqqtOUMOHMnMFhJl1FgtA1go4BhY9v6uz9VExw
and the resulting pptx at: https://mega.co.nz/#!I09E1SCR!UgqqGT6dIX7h67f86_m5XFsbrsMBhlLmjxIVjbflEiQ
Comment 3 ahitagni.mandal 2013-06-28 17:25:17 UTC
PPTX shown as corrupt in Microsoft Office Professional Plus 2010 SP1 32bit in Windows XP SP3 offers to repair.
PPTX also shown as corrupt even in Office 2007 in Windows XP SP3 offers to repair.

Exported again the supplied odp file in LibreOffice 4.1.01RC in Debian 7 32bit produced same error when tried to open in Office 2007 or Office 2010
Comment 4 retired 2013-12-13 11:07:57 UTC
Clemens, thanks for the files.

WORKSFORME with LO 4.3.0.0alpha0+ and 4.2.0.0b2 but not with 4.1.3.2.

Could you please test, if this bug is still valid / reproducible with the latest LO pre-release?  Currently 4.2.0.0beta2: http://www.libreoffice.org/download/pre-releases/

Should that be the case, please re-open this bug.