Bug Hunting Session
Bug 66274 - UI: Saving document as RTF result in text 'Use Rich Text Format Format'
Summary: UI: Saving document as RTF result in text 'Use Rich Text Format Format'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium trivial
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.2.0 target:4.1.1 target:...
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
: 66320 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-27 20:38 UTC by Dmitry Chestnykh
Modified: 2015-12-15 12:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the "Confirm file format" dialog (40.86 KB, image/png)
2013-06-27 20:38 UTC, Dmitry Chestnykh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Chestnykh 2013-06-27 20:38:43 UTC
Created attachment 81584 [details]
Screenshot of the "Confirm file format" dialog

Problem description: 

Steps to reproduce:
1. Open RTF document and change something in it.
2. Click File > Save.


Current behavior:

Dialog "Confirm File Format" appears asking to choose a format.
In this dialog there are two buttons:

"Use Rich Text Format Format"

and

"Use ODF Format"

From this we can conclude that Writer has Redundant Acronym Syndrome syndrome.


Expected behavior:

"Use Rich Text Format" and "Use ODF" or "Use OpenDocument Format".

or better:

"Save as Rich Text Format" document and "Save as ODF document"

as we're not "using" format, we saving.
Operating System: All
Version: 4.0.4.2 release
Comment 1 David Tardon 2013-06-28 04:41:47 UTC
(In reply to comment #0)
"Save as ODF document"

Yes, let's replace "Open Document Format format" by "Open Document Format document" .-)
Comment 2 Dmitry Chestnykh 2013-06-28 09:03:29 UTC
(In reply to comment #1)
> (In reply to comment #0)
> "Save as ODF document"
> 
> Yes, let's replace "Open Document Format format" by "Open Document Format
> document" .-)

Oh! At least it's for "Save", not "Open" function. "Open Open Document Format format document". :-D
Comment 3 Jorendc 2013-06-28 11:08:05 UTC
:D

Thanks for reporting! I can confirm this behavior using Mac OSX 10.8.3 with LibreOffice 4.1.0.1 -> NEW. Trivial bug (see https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg), so marking it as such.

Kind regards,
Joren
Comment 4 Julien Nabet 2013-06-30 21:03:14 UTC
*** Bug 66320 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2013-06-30 21:08:02 UTC
Bjorn: since this one is older than fdo#66320, I put this last one as dup and add copy paste the Whiteboard values. If you prefer I revert this, don't hesitate to tell me, I'll do it.


David: Just for information, I had suggested some ways to fix this here:
https://bugs.freedesktop.org/show_bug.cgi?id=66320#c1
But don't know if one of them is really ok.
Comment 6 Gergely Mate 2013-07-19 17:47:01 UTC
I suggest Julien's first solution:

1) replace "Rich Text Format" by "Rich Text"
diff --git a/filter/source/config/fragments/filters/Rich_Text_Format.xcu b/filter/source/config/fragments/filters/Rich_Text_Format.xcu
index 4bb6a82..602ca42 100644
--- a/filter/source/config/fragments/filters/Rich_Text_Format.xcu
+++ b/filter/source/config/fragments/filters/Rich_Text_Format.xcu
@@ -21,7 +21,7 @@
         <prop oor:name="FilterService"><value>com.sun.star.comp.Writer.RtfFilter</value></prop>
         <prop oor:name="UserData"><value>RTF</value></prop>
         <prop oor:name="UIName">
-            <value xml:lang="x-default">Rich Text Format</value>
+            <value xml:lang="x-default">Rich Text</value>
         </prop>
         <prop oor:name="FileFormatVersion"><value>0</value></prop>
         <prop oor:name="Type"><value>writer_Rich_Text_Format</value></prop>

It's OK that "Rich Text" is in the previous file format list - it's Rich Text what we're saving.
Comment 7 Julien Nabet 2013-07-20 22:43:57 UTC
I've proposed the change here:
https://gerrit.libreoffice.org/4999
Comment 8 Commit Notification 2013-07-22 17:45:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb99d8238502fad55aa62c5cadb0c188cc61d067

fdo#66274: Saving document as RTF result in text 'Use Rich Text Format Format'



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-07-22 20:24:07 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb479f1b707478708b8ab8b09af994bd4e1759dc&h=libreoffice-4-1

fdo#66274: Saving document as RTF result in text 'Use Rich Text Format Format'


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-07-22 20:24:26 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3f0fd9dc42cc5767ba5512581203df5406f45a8&h=libreoffice-4-0

fdo#66274: Saving document as RTF result in text 'Use Rich Text Format Format'


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Julien Nabet 2013-07-22 20:27:40 UTC
So fixed from 4.0.5 and 4.1.1 versions.
Comment 12 Dmitry Chestnykh 2013-07-22 20:35:59 UTC
Great, thanks!
Comment 13 Björn Michaelsen 2013-07-24 07:04:57 UTC
@Dmitry Chestnykh: I just noted, you seem not to have send the public license statement to libreoffice @lists.freedesktop.org. Could you please do so as per https://wiki.documentfoundation.org/Development/Developers#Developers_and_Contributors_list
?
Thanks!
Comment 14 Dmitry Chestnykh 2013-07-24 08:19:57 UTC
(In reply to comment #13)
> @Dmitry Chestnykh: I just noted, you seem not to have send the public
> license statement to libreoffice @lists.freedesktop.org. Could you please do
> so as per
> https://wiki.documentfoundation.org/Development/
> Developers#Developers_and_Contributors_list
> ?
> Thanks!

Not sure why this is needed in this case, but I submitted the license statement anyway in case I decide to contribute something other than bug reports :)

Thank you.
Comment 15 Björn Michaelsen 2013-07-24 08:44:03 UTC
@Dmitry: Thanks!
Comment 16 Robinson Tryon (qubit) 2015-12-15 12:10:38 UTC
Migrating Whiteboard tags to Keywords: (EasyHack SkillCpp DifficultyBeginner TopicUI)
[NinjaEdit]