Bug 66280 - Double Print Previews in Native MacOSX Print dialog
Summary: Double Print Previews in Native MacOSX Print dialog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-27 21:32 UTC by Jorendc
Modified: 2015-04-30 08:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (143.66 KB, image/png)
2013-06-27 21:32 UTC, Jorendc
Details
LO 5 nightly WFM (61.65 KB, image/jpeg)
2015-04-30 08:32 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-06-27 21:32:21 UTC
Created attachment 81586 [details]
Screenshot

Double Print Preview in Print dialog. Mac OSX only (tested on Windows 8, not reproducible)

How to reproduce:

* Open Writer
* File > Print (or cmd + P)

Behavior: 2 print preview dialogs (see screenshot)

Tested using Mac OSX 10.8.4 with LibreOffice 4.1.0.1 RC

Kind regards,
Joren
Comment 1 Jorendc 2013-06-27 21:34:04 UTC
Ping pong :). Reproducible for you guys?

Thanks for your time!
Joren
Comment 2 retired 2013-06-27 21:44:16 UTC
Can confirm this with LO 4.1.0.1 OS X 10.8.4. Setting to NEW.
Comment 3 Jorendc 2013-06-27 21:46:13 UTC
@Caolan: Looks related to the UI conversion IMO? Not that big bug :), so please only if you have time for it.

Kind regards,
Joren

PS: you have to 'Show Details' on the Print Dialog to reproduce this behavior.
Comment 4 Caolán McNamara 2013-06-28 11:56:34 UTC
This is the "native" aqua print dialog so unaffected by the change of the "non-native" print dialog. I rather suspect that this is the way it has "always" been back to pre-libreoffice days (be good if someone can confirm that with the oldest MacOSX version of LibreOffice)

I imagine it wouldn't be too hard to remove the preview from aqua/source/gdi/aquaprintaccessoreview.mm but I wonder why (it seems anyway) it was deliberate implemented in the first place to have a preview when the surrounding system dialog has one too. Was/Is there some version of MacOSX which didn't have the preview or is there some problem with it.

tml/thorsten: have any idea why we have a preview in our macosx print dialog when the system provides one already ?
Comment 5 Alex Thurgood 2013-06-28 13:58:44 UTC
I seem to recall that this came about as a result of the switch to native CUPS instead of lpr/psprint within LO, but I could be wrong. It could also be a result of a change in OSX's CUPS management and print preview rendering over the years. I don't recall seeing this with OSX 10.4.


Alex
Comment 6 (unused account) 2013-07-01 08:30:30 UTC
bugzilla-daemon@freedesktop.org wrote:
> tml/thorsten: have any idea why we have a preview in our macosx print dialog
> when the system provides one already ?
> 
Sorry, not me at least.
Comment 7 QA Administrators 2015-04-01 14:42:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 8 Alex Thurgood 2015-04-01 17:04:55 UTC
Still there in

Version: 4.5.0.0.alpha0+
Build ID: 09f83e1f409853a6c6e4300287c4e50bad5b9d0b
Locale: fr_
Comment 9 steve -_- 2015-04-30 08:31:56 UTC
Seems to be WFM in LO Version: 5.0.0.0.alpha1+
Build ID: 2932d2db599c09ecce3faa2d627e9ee4f251183a
TinderBox: MacOSX-10.10@61, Branch:master, Time: 2015-04-29_01:47:02
Locale: de.UTF-8

screenshot attached

Please re-open if you disagree or I missed sth.
Comment 10 steve -_- 2015-04-30 08:32:12 UTC
Created attachment 115210 [details]
LO 5 nightly WFM