Bug Hunting Session
Bug 66361 - FILESAVE: [regression] Saving .odt as .doc mangles table layout
Summary: FILESAVE: [regression] Saving .odt as .doc mangles table layout
Status: RESOLVED DUPLICATE of bug 66165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2013-06-29 11:09 UTC by Aurimas Fišeras
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file (80.36 KB, application/vnd.oasis.opendocument.text)
2013-06-29 11:09 UTC, Aurimas Fišeras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurimas Fišeras 2013-06-29 11:09:26 UTC
Created attachment 81675 [details]
Original file

Saving the attached .odt as .doc mangles the table layout.

Problem is reproducible in latest build from git (Version: 4.2.0.0.alpha0+ 64d667ac29a258af5b847fc622070e585b077e11) and 4.0.4.2 (9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) on both Windows (32-bit) and Linux (64-bit).

In version 4.0.2.2 everything was fine.

How to reproduce:
1. Open the attached .odt file.
2. Save it as .doc.
3. Close it and open the saved .doc file.
4. The table is completely mangled.

Bibisect points to:
source-hash-684c502ed0a6782fe1b9c7d7cd1911a4a88b543a

git bisect log
# bad: [6ebb37131c6deacecd445f62acef16001479764a] source-hash-64d667ac29a258af5b847fc622070e585b077e11
# good: [c57c26517852e6d0c4ea75775db98f6d9b93561d] root
git bisect start '6ebb37131c6deacecd445f62acef16001479764a' 'oldest'
# bad: [2543cfd22b6764d44c57d46e681eee5a59320ee0] source-hash-ef61bc2934bb9ae27b366fce6e707533cd73c862
git bisect bad 2543cfd22b6764d44c57d46e681eee5a59320ee0
# good: [7734aa8b1b6eae33bdeefa87d74587abfc03d27d] source-hash-e48b708da6556b63408084e37f83a4777c4dabfd
git bisect good 7734aa8b1b6eae33bdeefa87d74587abfc03d27d
# good: [fc3244a3c07d510a46baf5f999d378d07277fe1d] source-hash-5e8402ade84ab1816d32793e3476521e1c5b1027
git bisect good fc3244a3c07d510a46baf5f999d378d07277fe1d
# bad: [f1dfc6ef68cd1950f9a253f99a97a89afdc041f0] source-hash-71124925511b5c36b3348e89692e25db7230976c
git bisect bad f1dfc6ef68cd1950f9a253f99a97a89afdc041f0
# good: [d12a7adedffa0839c3b8f61a8223c64fe737245b] source-hash-c78f40a6d837a5d84bd8c2ef9e4916fa64ec58c3
git bisect good d12a7adedffa0839c3b8f61a8223c64fe737245b
# good: [bceb20d4d154b4550265b33842b7d2248628a7f7] source-hash-eca1592a6d7ccd47aeeeb2457695728ae7053d63
git bisect good bceb20d4d154b4550265b33842b7d2248628a7f7
# bad: [f63e35cdcc2eb4689df5acd5c5867723018267a7] source-hash-684c502ed0a6782fe1b9c7d7cd1911a4a88b543a
git bisect bad f63e35cdcc2eb4689df5acd5c5867723018267a7
# good: [810528ed4a2be1609ef723054f77b985cf620f87] source-hash-f92a5927052f1e96ed864dd6bc6326531db4fd1f
git bisect good 810528ed4a2be1609ef723054f77b985cf620f87
# first bad commit: [f63e35cdcc2eb4689df5acd5c5867723018267a7] source-hash-684c502ed0a6782fe1b9c7d7cd1911a4a88b543a
Comment 1 Aurimas Fišeras 2013-07-01 17:01:05 UTC
I git bisected this regression to:
83ba821c10392c08334f7d8d3775fe3e8d08f8fd is the first bad commit
commit 83ba821c10392c08334f7d8d3775fe3e8d08f8fd
Author: Jian Hong Cheng <chengjh@apache.org>
Date:   Wed Nov 28 00:33:42 2012 +0000

    Fix #i120928: Import Graphic Bullets of MS Word Document
...
    Change-Id: I7b00590a9f05da745678b5ba99b6f6f4e870d197
    Signed-off-by: Cedric Bosdonnat <cedric.bosdonnat.ooo@free.fr>
    Signed-off-by: Fridrich Strba <fridrich.strba@bluewin.ch>
Comment 2 retired 2013-07-03 11:06:29 UTC
Can confirm this issue. Setting to NEW.
Comment 3 Aurimas Fišeras 2013-07-03 14:11:38 UTC
Noticed that latest git has it fixed.
Tracked it down to commit:
commit a201ae63ce798438057a1328dc644dc8b64fe4e8
Author: Michael Stahl <mstahl@redhat.com>
Date:   Mon Jul 1 19:04:38 2013 +0200

    fdo#66165: WW8 export: fix duplicated paragraph breaks
    
    MSWordExportBase::OutputTextNode(): in commit
    8f2a21eac4a904db3cc4c448179e2d2cf5878ef4
    (which is not merged) a "WriteCR( pTextNodeInfoInner );" was moved up
    a few lines, so it shows up as context in the other commit, and
    the bug is that the cherry-pick 83ba821c10392c08334f7d8d3775fe3e8d08f8fd
    erroneously adds this context line so now there are 2 WriteCR().
    
    Change-Id: I08434b284f3d8d8426fa997623be352c37d6c7c2

*** This bug has been marked as a duplicate of bug 66165 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:03:26 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]