Bug Hunting Session
Bug 66363 - FORMATTING: multipe first page header gets lost when saving in DOC and DOCX format
Summary: FORMATTING: multipe first page header gets lost when saving in DOC and DOCX f...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 13:42 UTC by bugquestcontri
Modified: 2015-04-20 11:10 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-06-29 13:42:22 UTC
Problem description: 

In a Writer file it is possible to have different headers for the first page and all following pages.

The first page header is replace with the header of the following pages when the Writer file is saved in doc- or docx-format and re-opened

This happens when the first line header is created by unchecking "Same content on first page" (If I am not wrong this functionality exists only since 4.0.)

However it is still possible to define in Page Styles a first page and default page. When doing it this way, the different headers remain.




Steps to reproduce:

1 - right click Default Style in the Page Styles in the Styles and Formatting window
2 -  modify Default Style
3 - enable header
4 - uncheck "same content on first page"
5 - apply page style
6 - enter several lines in first page header
7 - enter a single line in the header of one of the next pages
8 - save in doc/docx-format
9 - open => first page header is replace by the following header


Current behavior:

When using "unchecking "Same content on first page" and save in doc/docx format the first page header is replaced by the header of following pages

But when defining a frist page page style no loss occurs
 
Expected behavior:
When using "unchecking "Same content on first page" and save in doc/docx format the first page header and the header of the following pages remain different.
Operating System: Windows XP
Version: 4.0.4.2 release
Comment 1 Zoltan Laszlo 2013-07-05 12:54:48 UTC
Confirmed in Libreoffice 4.1.0.1, Win7 Home Premium x64.

In addition to the bug report:
After reproducing the bug as shown above and reopening the document, the first page header was empty. Rewriting the first page header and reopening the document again and everything behaves as normal - first page preserved and different. However, it is critical that you have to reopen and rewrite to obtain the result. It should work without this hassle.
Comment 2 QA Administrators 2015-04-01 14:42:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 3 bugquestcontri 2015-04-20 11:10:24 UTC
I made a test in 4.3.6.1 and cannot observe the bug anymore.