Download it now!
Bug 66378 - FILEOPEN: MS .xlsx Fails to import properly. Missing Border (2/6)
Summary: FILEOPEN: MS .xlsx Fails to import properly. Missing Border (2/6)
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 18:51 UTC by Luke
Modified: 2013-06-29 19:20 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
MS .xlsx file imports incorrectly (468.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-29 19:10 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 1-3 (376.59 KB, image/png)
2013-06-29 19:14 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-29 18:51:11 UTC
This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS xlsx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-2012SummerOlympics.xlsx document in calc
2. Open attached Demo-2012SummerOlympics.xlsx document in Excel2010/Office 365
3. Compare the documents. 

Note item #2 in the screenshot that the border is missing from the row.
Comment 1 Luke 2013-06-29 19:10:59 UTC
Created attachment 81708 [details]
MS .xlsx file imports incorrectly
Comment 2 Luke 2013-06-29 19:14:52 UTC
Created attachment 81714 [details]
Comparison of xlsx in Excel vs Calc 1-3
Comment 3 Markus Mohrhard 2013-06-29 19:20:35 UTC
Also Format As Table feature.

*** This bug has been marked as a duplicate of bug 66377 ***