Bug 66379 - FILEOPEN: MS .xlsx Fails to import properly. Data Missing Err:509 (3/6)
Summary: FILEOPEN: MS .xlsx Fails to import properly. Data Missing Err:509 (3/6)
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 18:53 UTC by Luke
Modified: 2013-06-29 19:21 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
MS .xlsx file imports incorrectly (468.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-29 19:11 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 1-3 (376.59 KB, image/png)
2013-06-29 19:15 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-29 18:53:18 UTC
This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS xlsx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-2012SummerOlympics.xlsx document in calc
2. Open attached Demo-2012SummerOlympics.xlsx document in Excel2010/Office 365
3. Compare the documents. 

Note item #3 in the screenshot instead of showing the data, there is an err:509
Comment 1 Luke 2013-06-29 19:11:32 UTC
Created attachment 81709 [details]
MS .xlsx file imports incorrectly
Comment 2 Luke 2013-06-29 19:15:02 UTC
Created attachment 81715 [details]
Comparison of xlsx in Excel vs Calc 1-3
Comment 3 Markus Mohrhard 2013-06-29 19:21:21 UTC
Uses the new reference syntax of the Format As Table feature.

*** This bug has been marked as a duplicate of bug 66377 ***