Bug Hunting Session
Bug 66380 - FILEOPEN: MS .xlsx Fails to import properly. category axis not displayed (4/6)
Summary: FILEOPEN: MS .xlsx Fails to import properly. category axis not displayed (4/6)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 19:00 UTC by Luke
Modified: 2015-05-24 18:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
MS .xlsx file imports incorrectly (468.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-29 19:11 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 4 (284.84 KB, image/png)
2013-06-29 19:15 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 5 (296.19 KB, image/png)
2013-06-29 19:16 UTC, Luke
Details
LO 4.3 status with "Per Participant" column copied from Excel (518.03 KB, image/png)
2014-04-01 06:44 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-29 19:00:56 UTC
This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS xlsx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-2012SummerOlympics.xlsx document in calc
2. Open attached Demo-2012SummerOlympics.xlsx document in Excel2010/Office 365
3. Compare the documents. 

Note item #4 and #5 in the screenshot that the category axis is not displayed
Comment 1 Luke 2013-06-29 19:11:56 UTC
Created attachment 81710 [details]
MS .xlsx file imports incorrectly
Comment 2 Luke 2013-06-29 19:15:49 UTC
Created attachment 81716 [details]
Comparison of xlsx in Excel vs Calc 4
Comment 3 Luke 2013-06-29 19:16:54 UTC
Created attachment 81717 [details]
Comparison of xlsx in Excel vs Calc 5
Comment 4 Jacques Guilleron 2013-07-01 16:24:17 UTC
Hi Luke,

I reproduce too with LO  4.2.0.0.alpha0+
Build ID: ce0383d2950d3b0da2c457c8a406c1229de53571 & Windows 7  Home Premium.

But as by double-clic on diagram, selecting Insert/Delete Axis and check what is needed, we display axis. There is no data lost and it is very easy to correct.
So I set Status to New and Importance to low, trivial. 

Have a nice day,

Jacques
Comment 5 Xisco Faulí 2014-03-31 15:48:18 UTC
Problems 4,5 and 6 are still reproducible with:
   - Libreoffice 4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
   - Libreoffice 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

However, with 
   - Libreoffice 4.3.0.0.alpha0 Build ID: b6a43bcbbf9e9a5655fd36fd4c8ef72d585f67b0 

Problems 4 and 5 are already fixed.
Comment 6 Luke 2014-04-01 06:44:37 UTC
Created attachment 96696 [details]
LO 4.3 status with "Per Participant" column copied from Excel

Charts 6 is missing data because of the Format As Table feature from Bug 66377. If you copy the plain text from the "Per Participant" column in Excel and paste in Calc, chart 6 will display correctly. So all 3 charts are showing legends now in 4.3. Nice work LO team! 

The only remaining issue is that the "2012 Percentage" and "Medals per Participant" charts need to manually set:
Format Axis -> Text Flow -> "Overlap"

While the "Medals vs. Athletes per Country" chart needs:
Format Axis -> Text Flow -> "break"

Are these values something that the Calc importer could extract from the .xlsx file or determine automatically?
Comment 7 Luke 2014-04-01 06:53:07 UTC
In my previous post on "2012 Percentage" and "Medals per Participant" charts, I should have said to fix the legend import errors, you need to manually set:
Format Axis -> Text Flow -> "Overlap"
Format Axis -> Text Orientation -> 45
Comment 8 Luke 2015-05-24 18:17:59 UTC
This issue has been fixed in 5.0 with all the chart importer updates.