Bug Hunting Session
Bug 66381 - FILEOPEN: MS .xlsx Fails to import properly. chart not displayed (5/6)
Summary: FILEOPEN: MS .xlsx Fails to import properly. chart not displayed (5/6)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 19:06 UTC by Luke
Modified: 2013-07-02 18:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
MS .xlsx file imports incorrectly (468.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-29 19:12 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 5-6 (296.19 KB, image/png)
2013-06-29 19:17 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-29 19:06:19 UTC
This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS xlsx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-2012SummerOlympics.xlsx document in calc
2. Open attached Demo-2012SummerOlympics.xlsx document in Excel2010/Office 365
3. Compare the documents. 

Note item #6 in the screenshot that the chart is not displayed
Comment 1 Luke 2013-06-29 19:12:18 UTC
Created attachment 81711 [details]
MS .xlsx file imports incorrectly
Comment 2 Luke 2013-06-29 19:17:43 UTC
Created attachment 81718 [details]
Comparison of xlsx in Excel vs Calc 5-6
Comment 3 Jacques Guilleron 2013-07-01 13:47:29 UTC
Hi Luke,

This is a natural consequence of error 509 in column I for the not still implemented Table function.

Jacques
Comment 4 Jacques Guilleron 2013-07-02 18:45:40 UTC
Just close this report as Not a bug.

Jacques